Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to ping a certain domain (specifically, but the request times out.

Despite this error, the site loads in both Internet Explorer and FireFox without any issues.

Any idea what could cause this? I can give you some more background on how the situation came up if you'd like.


share|improve this question

Firewall is set to reject pings (icmp echo-request packets (Type 8)). It's pretty common actually.

Nmap gives me:

80/tcp   open     http            Microsoft IIS webserver 6.0
443/tcp  open     ssl/http        Microsoft IIS webserver 6.0

With an 88% chance of Windows 2003 server (Service Pack 1)

Someone needs to update that machine. Sp 2 came out 2 years ago.

@Dan: What are you using to do the url spidering?

share|improve this answer
Thanks for the quick response- Do you mean the firewall on their end? I'm trying to run a link-checking algorithm to test for bad URL's, and the HTTP request returns a 403 code (Forbidden) for that site, even though it opens fine in a browser. I tried pinging it, and that failed as well. Is there anything I can do about this, or should I just accept it as an issue with that specific domain? – Dan J Dec 15 '09 at 16:49
If the link-checking utility is getting a 403 Forbidden message, it is possible that the web server restricts the 200 OK response to specific user agent strings. has more information about user agent strings. Perhaps the link-checking utility can be configured send a different user agent that is allowed by the web server. – eleven81 Dec 15 '09 at 16:55
@satanicpuppy- I'm using functions from wininet.dll (HttpOpenRequest, HttpSendRequest, and HttpQueryInfo) to check for a 200 OK response for a given site. It's returning a 403 for this one, which is then considered a bad URL even though it really isn't (can still be opened in a browser). – Dan J Dec 15 '09 at 17:04

So what? Even opens in a browser but doesn't reply to ping due to ICMP blocking.

share|improve this answer

The ICMP ping port is most likely closed either at your end or their end, which is a very standard thing to do. If you are trying to use PING to resolve a name, I'd rather use the nslookup command instead. There is no reason to ping sites today, to see whether they are responding, except on your own local network.

Usually, servers on the internet will have only opened the ports that are required to do their business, such as 80 and 443 for HTTP and HTTPS, as well as 25 for email. There may be others, of course such as ftp(20-21) and SSH (22), but those are the standard ones.

In the same way, organizations will only open ports that the internal users need to perform business on the internet, and the same ports are usually the ones always opened. On top of that, they may restrict where they can go out, to avoid wasting bandwidth.

share|improve this answer
That makes sense then why I wouldn't be able to ping successfully, but can still get an HTTP request back. The only thing I'm still not sure about is how the response returns a 403 code (forbidden) when I send one manually (see my comment in the answer above from @satanicpuppy), but works fine from a browser. Is this a common setting as well? The same function has been used to check thousands of links, and I've never ran into this before. – Dan J Dec 15 '09 at 18:39
That might be because your browser has some cookies that the web site can interact with. This might also be because the web site filters the clients, based on the browser. Every HTTP client (be it wget on command line, Firefox or IE) have an ID string which is returned to the server. the server may have scripting based on this ID. Opera lets you change this string to anything you want, so you can trick some web sites. – jfmessier Dec 17 '09 at 15:10

You must log in to answer this question.