Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After searching in my start menu and clicking to "see more results", I got an error dialog:

enter image description here

It "seems" that it should be search-ms:query=document an not search:query=document but where can I fix this?

Additional info:

  • New user account don't have the problem.
  • Windows 7 Ultimate - RTM
  • Disabling/Enabling again "Windows Search" (in Start > Control Panel > Programs > Turn Windows Features on or off) doesn't fix it.
  • (There's a HKEY_CLASSES_ROOT\Search in my registry that's not there normally.) -> outdated see comments...


It could help me to diagnose, if someone send me any (hidden) files in %userprofile%\searches and some others pieces of registry:

  • HKEY_CLASSES_ROOT\.search-ms
  • HKEY_CLASSES_ROOT\.searchConnector-ms
  • HKEY_CLASSES_ROOT\SearchFolder
  • HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Associations\UrlAssociations\SEARCH
  • HKEY_CURRENT_USER\Software\Microsoft\Windows Search
  • Any other related key that I don't have seen...
share|improve this question
Are you using a full version or still a Beta release? – John T Dec 15 '09 at 17:52
full version, i have updated my post... – fluxtendu Dec 15 '09 at 17:55
Does a reboot fix anything? – John T Dec 15 '09 at 18:03
reboot don't fix anything – fluxtendu Dec 15 '09 at 18:06
what does the new registry setting contain? It's in my registry, and I've not experienced your problem (Win7 Pro) – Morten Bergfall Jan 2 '10 at 22:23
up vote 5 down vote accepted

Not sure whether you found a solution to your problem, but I had the same issue on my PC (running Windows 7 Pro 64 bit), and found the fix here.

NOTE: Using this fix will all your search/indexing options and cause you index to be rebuilt.

I would suggest you to try these steps and check.

Important: The instructions below contain steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information view the article in the Microsoft Knowledge Base: How to back up and restore the registry in Windows

  1. Press Windows + R (Opens the "Run" window)

  2. Type regedit and press Enter.

  3. In registry editor, locate

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search
  4. In the right pane, right click on SetupCompletedSuccessfully and click on Modify.

    NOTE: If SetupCompletedSuccessfully is not there, then in the right pane, right click on a empty area and click on New select DWORD (32 bit) Value and type SetupCompletedSuccessfully and press Enter.

  5. Type 0 and click on OK.

    NOTE: This is the number zero. Note that when you zero the value below, the system will erase all your parameters you entered in the index options, a.k.a. the directories you list. So you'll be back to default values.

  6. Close Regedit

  7. Restart the computer

share|improve this answer
Many thanks, I was hopeless and it worked! I would accept your answer but I can't... :( I don't know why, maybe because I have offer a bounty without accepted answer – fluxtendu Feb 9 '10 at 14:15

This article might contain the solution to the problem:

Fix Search Association Settings in Vista

Although it is for Vista, it might still pertain for Windows 7. The article contains registry fixes, so I suggest to create a system restore point before applying this fix, just in case.

share|improve this answer
Doesn't work, still the same error: doesn't find search:query= ... Maybe I'm gonna transfer all on another account... – fluxtendu Dec 22 '09 at 0:11
You can also use Process Monitor to try and figure out what is happening and so what part in the registry is wrong. – harrymc Dec 22 '09 at 7:03
Compare this with another account. – harrymc Dec 22 '09 at 11:10
It's really hard to figure out what's happening with process monitor because explorer.exe is involved and I must use the start menu just before launching the shortcut. So I don't know how to set my filters rules, it's either too fastidious or too restrictive – fluxtendu Dec 25 '09 at 15:53
Start PM first. – harrymc Dec 25 '09 at 17:43

I had a client with a similar issue, I exported the HKCR\search and HKCR\search-ms from a working machine and that seemed to fix it.

I have uploaded the .reg file I used.

share|improve this answer
Doesn't work, it's exactly what I already have in my registry... Thx anyway – fluxtendu Jan 3 '10 at 0:25
ok... I think I know what may be wrong then, I am to tired to try now, but please recheck my answer tomorrow and I will edit with another answer – William Hilsum Jan 3 '10 at 0:34

Without admin rights to access the registry, I used the suggestion of this link and fixed the issue:

In accordance with the Stack Overflow tradition, I am copying the original content of above link in case it goes away in the future. The steps:

1st – Right click on the Windows Start button, and click “Properties”
2nd – Click “Customize”
3rd – Scroll down until you find “Search other files and libraries”. Move the radio
        button from “Search with public folders” to “Search without public folders”, 
        click “OK”, and click “OK” on the previously opened window
share|improve this answer
Although this may answer the question, you should give a more detailed description of the linked content and explain how it relates to the question. This will help ensure that this answer remains useful in the event the linked page goes is removed or goes offline. For more information, see this Meta Stack Exchange post. – bwDraco Jan 27 '15 at 21:12
Worked for me, thanks – Andreas Huppert May 27 '15 at 10:45

The problem is a matter of user permissions, you go to the folder c: \ User \ yourouser and Right click mouse properties, click on security then changes and add a new user who will be called Everyone. Press OK to numerous warnings.

share|improve this answer
Poor quality answer. there's no indication the problem is security or permissions – Lizz Dec 27 '12 at 11:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .