Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i want to connect two machines i have set up a home network in my two computers and i have put them in the same workgroup as i turened off my windows firewall.

the 1st computer it OS:XP it has an 802.11 b wireless Lan card, i have configured as a host to share my internet connection, i have change the internet protocol TCP/IP proprieties and i have put them as below the ip adress :192.168.0.1 the subnet mask :255.255.255.0 the default gateway :192.168.0.1 the preffered DNS server :192.168.0.1

the 2nd is a dell laptop it OS: xp it wireless Lan card: 802.11 h+d, i have also change the internet protocol TCP/IP proprieties and i have put them as below the ip adress :192.168.0.3 the subnet mask :255.255.255.0 the default gateway :192.168.0.1 the preffered DNS server :192.168.0.1

the wireless connection is excelent but when i ping 192.168.0.3 using my laptop i receive the message requested time out and when i ping 192.168.0.1 using my computer i receive the same error message and when i go to my network places i just find the pc i am using it!

no file sharing neither internet sharing, and an excelent wireless connection. how could it be!!

best regards, Rim

share|improve this question
add comment

migrated from stackoverflow.com Dec 15 '09 at 20:34

This question came from our site for professional and enthusiast programmers.

2 Answers

The built-in firewall in XP filters out ICMP Ping by default. You'll need to adjust the settings to let ICMP Ping work over the wireless network.

To see whether or not the systems can find each other at all, look at the ARP cache. This is the Address Resolution Protocol cache and holds information mapping IP addresses to MAC addresses for local networks. After host B first tries to exchange traffic with host A, if A is on the same network as B and reachable, then B's ARP cache will say which MAC address to use. Try running arp -a to see if this works.

If the ARP cache doesn't show anything, you have more fundamental communication problems; perhaps your wifi is not in AdHoc mode, or the first computer's wifi isn't set to AP mode.

If the ARP cache shows something, then the firewall is blocking the ICMP Ping.

I'd have a thorough look through all the firewall settings on the first computer.

share|improve this answer
add comment

this is something I had before. Sometimes you can do a lot, but nothing helpes.

There are a few things you can try.

First of all, use the wizzard to make your home network really work. I did have these problems a few times, did everything right, but no good working home network.

A setup guide to home networking is found here

About the pinging problem, could it be that you have other programms running like antivirus software that might block your network? Please close those first and then try the network wizzaard in the link I provided you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.