Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I run the Pandora desktop gadget on my Win7 machine at work. I listen w/headphones, but since the headphone jack is on the front of the machine, sometimes my foot catches the cord and pulls it out. When this happens (or any time the headphones are pulled out), Pandora stops playing and has to restart/reconnect. Is there some reason why this happens, and how can I prevent it (short of being less clumsy)?

share|improve this question
    
Is it good to have your feet on the desk while you're working? –  pavium Dec 16 '09 at 0:52
    
ha, cute. my machine is on the floor :) –  Jason Dec 16 '09 at 18:27

2 Answers 2

If your sound card uses SoundMAX drivers then you could try to disable the Change speaker configuration automatically option and hope for the best:

Screenshot

share|improve this answer
    
not using soundmax... thanks tho :) –  Jason Dec 17 '09 at 23:04
    
Fair enough. So, mind if I ask what you're using? –  Saxtus Dec 18 '09 at 0:33
    
i have the basic win7 configuration... in my device manager it says "High Definition Audio Controller" –  Jason Dec 31 '09 at 19:51
1  
You should download the drivers for the specific soundcard your PC is using by going to it's manufacturer's website, because the Windows default driver apparently is missing many options. –  Saxtus Jan 1 '10 at 16:14

This may or may not help, but I've noticed that (hardware permitting I assume) Windows 7 recognizes the fact that audio devices are being (dis)connected, and will occasionally pop up an alert when you plug in a new microphone, for instance.

Have you tried going into the 'sound' control panel item, looking at your 'speakers' properties in the 'playback' tab, tabbed over to 'advanced', and trying different checkboxes in the 'exclusive mode' section? That's what I'd try first if I were running into that problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.