Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to follow the Facebooker tutorial (for Ruby on Rails) but I can't get the ssh tunnel running:

Bring up your terminal again. You need to start your local development server, and then make that server available to the wider internet. Do this like so:

script/server &  
rake facebooker:tunnel:start &

Once your server has started, the second command will start a reverse ssh tunnel.

When I execute the second command, I get the following:

user@computer:~/facebooker-test$ rake -t facebooker:tunnel:start 
(in /home/user/facebooker-test)  
** Invoke facebooker:tunnel:start (first_time)  
** Invoke environment (first_time)  
** Execute environment  
** Invoke facebooker:tunnel:config (first_time)  
** Invoke environment  
** Execute facebooker:tunnel:config
** Execute facebooker:tunnel:start
Starting tunnel :4007 to 0.0.0.0:3000
OpenSSH_5.1p1 Debian-6ubuntu2, OpenSSL 0.9.8g 19 Oct 2007
usage: ssh [-1246AaCfgKkMNnqsTtVvXxY] [-b bind_address] [-c cipher_spec]
           [-D [bind_address:]port] [-e escape_char] [-F configfile]
           [-i identity_file] [-L [bind_address:]port:host:hostport]
           [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]
           [-R [bind_address:]port:host:hostport] [-S ctl_path]
           [-w local_tun[:remote_tun]] [user@]hostname [command]
user@computer:~/facebooker-test$

Apparently, there's some sort of incompatibility between the rake task's ssh command, and the correct syntax.

I'm using Ubuntu 9.10 with the openssh-server package, and the facebooker plugin for Ruby on Rails out-of-the-box from github.

Any ideas?

share|improve this question
up vote 1 down vote accepted

okay, I've figured it out. Apparently, I was missing some definitions in my facebooker.yml file.

I had to put in the host and usernam.

I discovered this by going into vendor/plugins/facebooker/lib/tasks/tunnel.rake and putting adding the following line to the end of the :config directive:

@notification <<"using the following ssh command: \n #{@ssh_command}"

Then, when I call rake with -t option, I get an output of how the command will be executed. I saw a trailing @ at the end of the command, and realized what was missing. Yay me!

share|improve this answer
    
Yay you! 15 chars – Sathya Dec 16 '09 at 14:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .