Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on Windows XP.

Some time ago, while trying out a number of different font management programs, something went wrong. I don't know what happened but now some applications, in some of their GUI controls, use the System(12) font instead of the Windows default one (which should be Microsoft Sans Serif 8, I think).

This happens, for example, with most installers (at the beginning of the installation, in subsequent dialogs the fonts display just fine), and a number of programs.

Here's Microsoft/Sysinternals' Autoruns:

Autoruns

You can see the tab names, as well as the text in the bottom panel, displayed with the System(12) font. On a different machine, they simply use "MS Sans Serif 8" (detected using HwndSpy).

I tried:

  • deleting the Windows font cache file (c:\windows\system32\fntcache.dat)
  • modifying the registry values for "MS Shell Dlg" and "MS Shell Dlg 2", as explained here

...to no avail.

Any suggestions on what else I could try to have the default font back?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

You've probably uninstalled the ‘MS Sans Serif’ font.

Autoruns's dialog resources are all specified with the property:

FONT 8, "MS Sans Serif"

Instead of one of the more usual UI fonts such as the ‘MS Shell Dlg’ mapping. So without ‘MS Sans Serif’ or any substitute available, Windows falls back to the horrible last-resort default font, ‘System’.

‘MS Sans Serif’ is a bitmap font so even on a standard system Autoruns's windows may not look right as ClearType won't be used, as it would be with the default ‘MS Shell Dlg’ mapping to Tahoma or ‘Microsoft Sans Serif’ (which is a different font to ‘MS Sans Serif’, just to confuse you).

So re-installing the font (file ‘sserife.fon’) should restore the usual behaviour... alternatively you could set a FontSubstitute to map it to another font you do have installed, such as:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes]
"MS Sans Serif"="Tahoma"
share|improve this answer
    
+1, because you: 1) by mentioning "resources" helped me remember that I could have just used a resource editor to get at the font used in the program dialog (instead of using a Window Spy program); and 2) mentioned the name of the font, pointing me at the direction where the solution stood, waiting. The font was in the right folder but, as you say, uninstalled. Thanks again. –  TataBlack Dec 16 '09 at 15:31

I have problem like described (System font displayed instead of MS Sans serif) on Windows 7 x64 with additional symptoms - Fonts in Control panel displays Arial instead of MS Sans serif. Problem was solved after switching regional settings location and non-Unicode program language forth to English (USA) and back to my original setting (Russian, Russia). I suppose that switching only non-Unicode program language forth and back should be enough.

share|improve this answer

Right click on the desktop and choose Properties.

Next, select the Appearance tab and click advanced.

You should be able to change a few of the default fonts from here.

alt text

If this still doesn't fix it, it seems like something is broken at the system level.

Go to a Command Prompt window and type the following: SFC /SCANNOW which should scan and replace and system files.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.