Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Windows 7 x64 machine, which has 4 drives in it. One of the drives disappears when the computer resumes from sleep. It is consistently the same drive. It disappears from my computer, and if I go to the disk management console. If I reboot, then it reappears. Any ideas what might cause this and how I might fix it?

Edit 2:

Some more background. This machine used to have XP on it and I had no issues then, all drives worked ok, and machine could sleep/wake with no problems. This issue started when I upgraded to Windows7 x64, and only affects one drive... Sometimes if it only sleeps for a little while the drive is still there, but if it sleeps for 20 mins+ then it always disappears


Its a SATA drive, connected to the via onboard controller.

Make and model of the motherboard from SIW:


Property    Value

Model               F-I90HD (ATI RS600-SB600)
Version          1.0
Serial Number    

North Bridge        ATI Xpress 1250 (RS600) Revision 00
South Bridge        ATI SB600 Revision 00

CPU Genuine Intel(R) CPU 2160 @ 1.80GHz
CPU Socket  Socket 775 LGA

System Slots    3 PCI

Memory Summary   
Maximum Capacity    2048 MBytes
Maximum Memory Module Size  32 MBytes
Memory Slots    4
Error Correction    None

The disk information for the relevant disk from the storage devices node is:

Disk 1

    Manufacturer     Maxtor
Model    Maxtor 6V300F0
Size     300.0 GB
Firmware Version     VA111630
Serial Number    V60DA53G
Interface    Serial ATA
Standard     ATA/ATAPI-7 | ATA/ATAPI-7 T13 1532D version 0
Transfer Mode (Current / Max)    SATA-300 / SATA-300
Features     S.M.A.R.T., APM (Disabled), 48bit LBA, NCQ, AAM
Temperature  54 C (129 F)
Drive Letter(s)  D:
Controller Buffer Size on Drive  16384 KB
Removable    No
Cache Enabled (Read / Write)     Yes / Yes
SMART Support    Yes
Attribute Name   Attribute Value Worst Value Threshold Value Raw Data
Spin Up Time (03)    187 184 063 000000006083
Start/Stop Count (04)    253 253 000 00000000050E
Reallocated Sector Count (05)    253 253 063 000000000000
Seek Error Rate (07)     253 252 000 000000000000
Seek Time Performance (08)   246 233 187 0000000094FC
Power On Hours Count (09)    181 181 000 000000006297
Spin Retry Count (0A)    253 252 157 000000000000
Calibration Retry Count (0B)     253 252 223 000000000000
Power Cycle Count (0C)   252 252 000 0000000002F5
[unknown] (BD)   100 100 000 000000000000
Airflow Temperature (BE)     046 031 000 000036290036
Emergency Retract Cycle Count (C0)   253 253 000 000000000000
Load/unload cycle count (C1)     253 253 000 000000000000
HDA Temperature (C2)     053 253 000 000000000036
ECC On The Fly Count (C3)    253 251 000 0000000018EC
Reallocation event count (C4)    253 253 000 000000000000
Current pending sector count (C5)    253 252 000 000000000000
Off-line uncorrectable sector count (C6)     134 134 000 000000000077
Ultra ATA CRC Error Rate (C7)    001 001 000 00000000397D
Multi Zone Error Rate (C8)   253 252 000 000000000000
Off Track Errors (C9)    253 252 000 000000000001
Data Address Mark Errors (CA)    253 251 000 000000000000
ECC Errors (CB)  253 252 180 000000000000
Soft ECC Correction (CC)     253 252 000 000000000000
Thermal Asperity Rate (CD)   253 252 000 000000000000
Spin High Current (CF)   253 252 000 000000000000
Spin Buzz (D0)   253 252 000 000000000000
Vibration During Write (D2)  253 252 000 000000000000
Vibration During Read (D3)   253 252 000 000000000000
Shock During Write (D4)  253 001 000 000000000000

and the information from the devices->disk drives node for the drive:

Property    Value
Device ID   IDE\DISKMAXTOR_6V300F0__________________________VA111630\533DDAC6301.0.0
Status  0x0180200a Started
Problem 0x00000000 (0)
Service disk
Capabilities    0x00000000
Config Flags    0x00000000
Class   DiskDrive
Manufacturer    (Standard disk drives)
Hardware IDs    IDE\DiskMaxtor_6V300F0__________________________VA111630
Compatible IDs  GenDisk
Class GUID  {4d36e967-e325-11ce-bfc1-08002be10318}
Location    Channel 1, Target 0, Lun 0
Enumerator name IDE
Description Disk drive
Friendly name   Maxtor 6V300F0 ATA Device
Driver  {4d36e967-e325-11ce-bfc1-08002be10318}\0001
Physical Object Name    \Device\IDE\IdeDeviceP1T0L0-1
UI number   0x00000000
Install State   0x00000000
Device Address  0x00000000

Device Configuration File   disk.inf
InfPath disk.inf
InfSection  disk_install
InfSectionExt   .NT
ProviderName    Microsoft
DriverDateData  00 80 8C A3 C5 94 C6 01
DriverDate  6-21-2006
DriverVersion   6.1.7600.16385
MatchingDeviceId    gendisk
DriverDesc  Disk drive

Class   DiskDrive
ClassDesc   @%SystemRoot%\System32\StorProp.dll,-17000
    Disk drives
IconPath    %SystemRoot%\System32\imageres.dll,-32
Installer32 StorProp.Dll,DiskClassInstaller
NoInstallClass  1
SilentInstall   1
UpperFilters    PartMgr
share|improve this question
by restarting "explorer.exe" can you get them back ? – user8228 Dec 17 '09 at 13:57
nope. I tried killing and restarting explorer.exe, but no joy. As I said they have disappeared from the disk management console and everything. – Sam Holder Dec 17 '09 at 17:36
I had a similar issue in xp/vista with a sata drive. Later found out it was a bad port on my mobo. – MrStatic Dec 17 '09 at 22:36
I was thinking of something along the lines of a bad port also. Have you tried plugging the HDD into a different port? – MetalMikester Dec 18 '09 at 12:26
by 'in it' i suppose it is an internal drive. IDE? SATA? connected to the onboard controller or add-on card? please post make and model of the mainboard, the hard disk in question (and the controller, if not onboard), SIW will give you the necessary information: – Molly7244 Jan 5 '10 at 14:46

Been seeing this with a number of drives - 1TB satas - when resuming for s3 sleep.

Check to see if your drive supports s3 sleep mode: Please first check if your secondary drive support S3 in Windows 7:

Step 1:

  1. Click the Start button, then in the "Start Search" box, type CMD but DO NOT press Enter yet.
  2. In the list above, under "Programs" right-click on CMD that appears above and choose "Run as Administrator" and click "Continue".
  3. In the open window, type the following command and press Enter:

Powercfg /devicequery s3_supported

Step 2: Disable write caching on the secondary drive

  1. Click the Start button, then in the "Start Search" box, type DEVMGMT.MSC but DO NOT press Enter yet.
  2. Right click "Disk drivers/your secondary drive" and choose properties.
  3. In Policies tab, uncheck the option "Enable write caching on the device".

Some have fixed this by installing the Intel Matrix storage drivers

Others by forcing the drive from AHCI to IDE mode (bios setting)

share|improve this answer
Thanks for the suggestions. The powercfg command lists the drive. unchecking the write caching didn't fix it, as it has disappeared again. I wasn't able to install the drivers, just getting a 'computer does not meet the minimum requirements for this software' message. The drive is already in IDE mode, and infact doesn't appear in the list of drives in the bios if I change to AHCI mode. – Sam Holder Jan 5 '10 at 19:40
I've had similar problem on Win7 and Win10. Secondary HDD (WD VelociRaptor 300GB) was suddenly missing after resume. The solution was to install Intel Rapid Storage Technology drivers. – ge0rdi Mar 8 '15 at 18:16

Take a look at which deals with resume problems with disks >1Tb in size. The KB refers to STOP messages rather than the drive disappearing, but then you would expect a STOP if the missing drive was the system drive.

share|improve this answer

try the drive with a another cable and/or on a different port and check whether the problem persists.

share|improve this answer
ok I'll try. The turnaround is not too quick though, as if I wake it from sleep immediately then the drive is still there. I need to wait 20 mins for it to disappear – Sam Holder Jan 5 '10 at 21:12
now that's very weird indeed. you may add this info to your post. – Molly7244 Jan 7 '10 at 12:07

The logs that you provided say two thing about that hard drive, the first being S.M.A.R.T is disabled in the bios for that particular drive. The second being the Shock During Write (D4) 253 001 000 000000000000 Smart threshold seems to have been tripped or at the very least is close to failure.

You should go into the bios and enable smart for your hard drives then, once the system is booted with all drives listed. Download hd tune and run some tests to confirm the capabilities of that 300gb Maxtor drive.

share|improve this answer

To me, this sounds like the hard drive is simply slower at waking up / powering on than the others and your machine does not fully support hot-plugging.

If I was you, look in the BIOS for any option called "Hard Drive delay" or anything else with the word "delay" (or similar) on it and see if you can set it.

share|improve this answer
if there is a setting for delay should I increase it? – Sam Holder Jan 5 '10 at 21:11
usually it is just a on/off setting, but if it is editable, increase the delay. – William Hilsum Jan 5 '10 at 21:23
found something but only seems to be for IDEs. set it anyway, but hasn't made any difference. – Sam Holder Jan 7 '10 at 21:30

I have the same problem with one of my hard drives. I found it to be a precursor to hard drive failure. At first it would disappear after the computer went to sleep so I turned off sleep/hibernation. After that, I noticed the hard drive would occasionally click, freeze for about 5 seconds, and then come back online. If none of the other answers helped, you are probably looking at a bad drive that needs replacement.

share|improve this answer
up vote 0 down vote accepted

I wasn't able to solve this, but I was able to work around it. I plugged the drive into a raid card instead of being on the mobo (had to disable my raid to do this though) and plugged the drive that was in the raid into the mobo. now all drives work ok and don't disappear when it sleeps... weird.

share|improve this answer

You must log in to answer this question.

protected by studiohack Apr 27 '11 at 1:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .