Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to set up wifi on slackware, following this guide. Everything is good, and as you can see below I am able to join the network (Link Quality=75/100). However I cannot access anything, and ping just does not work. I tried to ping pages by IP address as well, but it failed so this is not a problem with DNS. Also, it appears that I cannot acquire an IP address
This is the result of iwconfig

wlan0     IEEE 802.11bgn  ESSID:"rmitvnnet"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:19:E1:0D:FB:04   
          Bit Rate=54 Mb/s   Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:off
          Power Management:off
          Link Quality=75/100  Signal level:-83 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

This is the result of ifconfig wlan0

wlan0   Link encap:Ethernet  HWaddr 00:22:43:61:a2:f0
        inet6 addr: fe80::222:43ff:fe61:a2f0/64 Scope:Link
        RX packets:4526 errors:0 dropped:0 overruns:0 frame:0
        TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:1000 
        RX bytes:779355 (761.0 KiB)  TX bytes:498 (498.0 B)

This is the result of ip addr show wlan0

4: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:22:43:61:a2:f0 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::222:43ff:fe61:a2f0/64 scope link 
    valid_lft forever preferred_lft forever

And this is my configuration in rc.wireless.conf

case "$HWADDR" in
    INFO="Multiband Atheros based 802.11a/b/g universal NIC"
share|improve this question
well I'm starting a bounty now... this is on my wish list – phunehehe Jan 4 '10 at 12:11
Please add the output of "ip addr show wlan0" or "ifconfig wlan0" so we know the layer 2 configuration. – camh Jan 4 '10 at 12:29
do other computers work on the wireless setup? – John T Jan 4 '10 at 20:42
@John T: yes the network is in use and other computers are working fine (most of them are using windows, a few using ubuntu which doesn't need to config anything) @camh: I'm going to upload that – phunehehe Jan 5 '10 at 4:14
Can you post your rc.wireless.conf? – John T Jan 5 '10 at 7:19
up vote 1 down vote accepted

Just wondering if you have tried running the dhcp client on wlan0 to see if it obtains an IP address automatically.

share|improve this answer
yeah cool thankyou this is just what I need – phunehehe Jan 5 '10 at 9:27
can't remember how to do it, but you can automate dhcp in the slackware init scripts too, probably one of the networking configurations, so that it does it whenever it starts up wireless networking. – sybreon Jan 5 '10 at 11:32
dhcpcd wlan0 just does its job, I'll go look further into automatic scripts – phunehehe Jan 6 '10 at 12:07
yeah and for the automatic dhcp, you need USE_DHCP[n]="yes" in /etc/rc.d/rc.inet1, where n is the index of your interface – phunehehe Feb 22 '10 at 3:35

You have no encryption key in your rc.wireless.conf, is there no encryption in place? If there is you'll need to add it. Also, try connecting without specifying a channel:

case "$HWADDR" in
    INFO="Multiband Atheros based 802.11a/b/g universal NIC"

Change password_here with your wireless key. If it still doesn't work, try setting the channel (if you know it).

You may also be interested in wicd. It is way easier than messing with rc.wireless.conf:

alt text

share|improve this answer
Thanks a lot John, but I don't have any key. BTW the other guy got the answer – phunehehe Jan 5 '10 at 9:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .