Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've had mixed results with using Windows Explorer to browse remote file shares.

The setup:

  • I'm at work on Windows XP SP3
  • Files are at home on Windows XP SP3
  • Two separate VPNs are available to access my PC at home
    • corporate OpenVPN (10.1.2.3)
    • a Hamachi/LogMeIn connection (5.1.2.3)

With respect to my problem, it doesn't matter which IP I use. They both perform exactly the same way:

I expect that if I open Windows Explorer and type in \\10.1.2.3\Shared I should be interrupted with a challenge for credentials, and then be able to interact with the files in the share. However, I just get that annoying dialog, "Windows cannot find '\10.1.2.3\Shared' Check the spelling and try again, or try searching for the item ..."

However, I can take that exact same computername/sharename and with net use I can:

net use * \\10.1.2.3\Shared * /user:homecomputername\username

with this result:

Type the password for \\5.69.83.158\C$:
Drive Z: is now connected to \\5.69.83.158\C$.

The command completed successfully.

I can then access the files in Z: in Windows Explorer which was my original intent.

Even after Z: is already mapped and the credentials are cached I still cannot bring up \\10.1.2.3\Shared in Windows Explorer.

Why does the latter work, but not the former?

Edit: Other services work fine, such as RDP. (I have a problem in which I can't SSH home, but I'll consider that separately.)

share|improve this question

3 Answers 3

up vote 3 down vote accepted

You're trying to access the share (in the first case) with your Windows credentials. Try 'connecting network drive' with a specific username/password in Windows Explorer.

share|improve this answer
    
That sounds reasonable, but I expected to be challenged with a dialog to enter those credentials, not to have to go through the "Map Network Drive" rigmarole. Essentially it's this explicit drive mapping I thought I could avoid. –  JMD Dec 17 '09 at 17:30
    
It depends - by default (some?) windows version don't prompt you for credentials. I'm sure there are registry keys that do exactly that. –  lorenzog Dec 17 '09 at 17:38

You likely have bad credentials stored with that network resources (Windows maintains a list of this) -- or none and therefore are trying to authenticate with your own credentials instead of the ones you need.

Please see this Microsoft article:

http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/usercpl_manage_passwords.mspx?mfr=true

There, you can manage what credentials Windows should use with which network resources.

share|improve this answer

Use \\Username@10.1.2.3\Shared, this works with my Windows XP

share|improve this answer
    
Thanks Thomas, that looked promising, but no dice in my particular case. I'm beginning to suspect some oddity either with the OpenVPN server setup here (outside my reach), or with my router or Windows Firewall at home. –  JMD Dec 17 '09 at 17:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.