Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my previous notebook, the Dell/Broadcom wireless adapter had an option to automatically disable wireless when a wired network is connected, so I never dealt with multiple active interfaces. My current system has an Intel wireless adapter, and they apparently haven't figured out how to turn it off when there is a wired connection. Unless I explicitly remember to disable wireless when docked, the connection is active.

That shouldn't be a problem (in theory), since the route metric will cause traffic to go over the fastest network (as indicated by the lowest metric in the routing table).

Apparently not - I'm running a backup and seeing the throughput at 25Mbps or so (which is consistent with 802.11g) when a perfectly good Gigabit Ethernet interface is also connected.

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0    192.168.1.254    192.168.1.104     10
          0.0.0.0          0.0.0.0    192.168.1.254    192.168.1.109     25
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    306

Windows has correctly identified the Ethernet interface (.104) and assigned it the lower (preferred) metric. So the Ethernet interface should be used exclusively, right?

Why is the Ethernet connection not being used? What other factors are involved? (This is with Windows 7 if it makes a difference)

Entire output of "route print" command (see comment below):

    C:\>route print
===========================================================================
Interface List
 11...00 18 de 3e 53 82 ......Intel(R) PRO/Wireless 3945ABG Network Connection
 10...00 15 c5 af 80 0e ......Broadcom NetXtreme 57xx Gigabit Controller
  1...........................Software Loopback Interface 1
 17...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter
 12...00 00 00 00 00 00 00 e0 Teredo Tunneling Pseudo-Interface
===========================================================================

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0    192.168.1.254    192.168.1.104     10
          0.0.0.0          0.0.0.0    192.168.1.254    192.168.1.109     25
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    306
      192.168.1.0    255.255.255.0         On-link     192.168.1.104    266
      192.168.1.0    255.255.255.0         On-link     192.168.1.109    281
    192.168.1.104  255.255.255.255         On-link     192.168.1.104    266
    192.168.1.109  255.255.255.255         On-link     192.168.1.109    281
    192.168.1.255  255.255.255.255         On-link     192.168.1.104    266
    192.168.1.255  255.255.255.255         On-link     192.168.1.109    281
        224.0.0.0        240.0.0.0         On-link         127.0.0.1    306
        224.0.0.0        240.0.0.0         On-link     192.168.1.104    266
        224.0.0.0        240.0.0.0         On-link     192.168.1.109    281
  255.255.255.255  255.255.255.255         On-link         127.0.0.1    306
  255.255.255.255  255.255.255.255         On-link     192.168.1.104    266
  255.255.255.255  255.255.255.255         On-link     192.168.1.109    281
===========================================================================
Persistent Routes:
  None

IPv6 Route Table
===========================================================================
Active Routes:
 If Metric Network Destination      Gateway
 12     58 ::/0                     On-link
  1    306 ::1/128                  On-link
 12     58 2001::/32                On-link
 12    306 2001:0:4137:9e76:3005:82a:b3a3:1099/128
                                    On-link
 10    266 fe80::/64                On-link
 11    281 fe80::/64                On-link
 12    306 fe80::/64                On-link
 11    281 fe80::11ad:fcef:18ff:97a9/128
                                    On-link
 12    306 fe80::3005:82a:b3a3:1099/128
                                    On-link
 10    266 fe80::9524:5f90:dd0:86fb/128
                                    On-link
  1    306 ff00::/8                 On-link
 12    306 ff00::/8                 On-link
 10    266 ff00::/8                 On-link
 11    281 ff00::/8                 On-link
===========================================================================
Persistent Routes:
  None
share|improve this question
1  
Assuming your backup is to another machine on the same network, you pasted the wrong part of your route table. The routes you are looking at (the first two in your paste) are default routes for off-network traffic. You didn't paste the interface routes. That's what controls where local traffic goes. We need to see the routes to the backup machine, not the routes to the Internet. –  David Schwartz Nov 20 '11 at 3:44
    
David - thanks for the insight - please see the edit above where I pasted more of the route table... –  tim11g Nov 21 '11 at 17:30
    
You still haven't pasted the routes this traffic is taking. You pasted loopback routes to 127.* addresses. I'm assuming the backup machine has a 192.168.1.* address. You haven't pasted the routes to that local network. –  David Schwartz Nov 21 '11 at 18:27
    
David - I have pasted in the full output of the "route print" command above. You are correct that all machines are on the 192.168.1.* network. Is there a different command for local network information? –  tim11g Nov 23 '11 at 20:14
    
The relevant routes are 192.168.1.0 255.255.255.0 On-link 192.168.1.104 266 and 192.168.1.0 255.255.255.0 On-link 192.168.1.109 281. It should take the route with the lower metric for destination these routes cover, which is 192.168.1.x -- and that's the interface with the address ending in .104, which is the wired Ethernet. In other words, the routing table looks correct and says to prefer the wired interface for other machines in your local network. –  David Schwartz Nov 23 '11 at 21:07
add comment

3 Answers

Your routing table looks good, now that we see the network routes. That should cover traffic that doesn't try to influence the networking stack. But some applications try to select an interface themselves, and generally, these applications will take the first suitable interface they find.

So let's make sure your wired interface is ahead of the wireless one. To do this, run ncpa.cpl from the Run bar. Under Advanced, select Advanced Settings. In the top pane, find your wired interface and select it. Hit the green up arrow just to the right to move that interface to the top. You will need to reboot to make sure all running programs see the new order.

(Though the KB article is for a different OS, the method and concept is the same.)

share|improve this answer
    
David, In Windows XP, I know exactly which dialog you're talking about, with the list of connections that can be re-ordered with the green arrows. However, the machine in question is running Windows 7, and ncpa.cpl brings up a dialog with no menus, and no visible way to get to the Advanced Settings dialog. I'm sure it's there somewhere, but it has become hidden. –  tim11g Nov 25 '11 at 23:14
    
Found it - it is one of those dialogs that hides the fact that a menu exists until you press ALT. –  tim11g Nov 25 '11 at 23:19
add comment

A long shot, but if you are running a backup to another local host on your LAN, perhaps that is changing things somehow.

Any TCP/IP stack can infer that, if a network adapter is set to something like 192.168.111.1 subnet 255.255.255.0, then it can reach any address 192.168.111.2 through 192.168.111.255 simply by sending traffic out of that interface. It wouldn't touch the default gateway, and indeed, Windows may be "short circuiting" for some reason and not bothering to consult the route table for a directly connected subnet.

It also may be due to NetBIOS sending out a broadcast on both interfaces and then Windows received a reply from your machines via the wireless first, so it continued to used that interface for further traffic. This is a very long shot, I don't know too much about the internals of NetBIOS.

share|improve this answer
    
It has to consult the route table. There may be a more specific route to that particular destination. –  David Schwartz Nov 21 '11 at 20:07
add comment

This may be helpful: http://support.microsoft.com/kb/299540 It implies that metrics are assigned specifically for the scenario you describe.

...except in your situation it isn't working. Without access to the source code or definitive information from Microsoft, it's pretty tough to tell why Windows is acting that way in your case.

My only 'guess' would be that maybe your wireless interface comes up first and Windows starts talking with certain remote machines--and those connections stick to the interface they started with to prevent an IP change during an established conversation (which would break the connection). Then you plug your laptop in to Gig Ethernet and Windows doesn't move established traffic over to that connection to avoid dropping those connections.

One way to test that would be to plug in via Ethernet, switch off the wireless and then verify you have fast connectivity. Then turn the wireless back on and see if you keep the faster connectivity.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.