Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Ubuntu 9.10 Server in VMWare Fusion (on a Mac) and I'm having trouble changing the console resolution. It seems to be stuck on 640x480.

Ubuntu 9.10 uses Grub2, so there is no /etc/grub/menu.lst.

I tried adding vga=791 to the kernel parameters (both during boot and by adding it to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub and then running update-grub2) and neither had any effect.

When using vga=791, grub says that vga=791 is depreciated and that I should use gfxpayload=1024x768x16,1024x768 instead. However, that also does absolutely nothing.

I have a feeling this problem is specific to running Ubuntu 9.10 in VMWare, but Google hasn't turned up anything.

share|improve this question
    
I am experiencing the exact same issue. Still haven't found a solution either. :( –  Sebastian Dwornik Dec 22 '09 at 15:54
add comment

4 Answers

Tried all of these with Ubuntu 9.10 Server as VMWare guest and WinXP Pro as host and they didn't work.

I eventually found that you had to edit /boot/grub/grub.cfg but using the old vga=773 in this file caused the boot to fail to configure the console and so I was almost stuffed as the console was now blank :( ... until I remembered that I'd installed the SSH service and was able to login to fix it using Putty. Then it dawned on me that by using Putty I got what I was after ... a resizeable colour console window (any number in fact) and so I didn't need to tweek the main VMWare console dimensions. Duh! Add WinSCP (Windows) or CuteFTP/FireFTP (OSX) and you don't need to use the VMWare console at all. Just let the Linux server be a server. No more Ctrl-Alt's to free the mouse and with WinSCP you can use a decent text editor and directory/file browser.

share|improve this answer
add comment

Well, I did a fair bit of googling and noodling and most everything suggested that adding "GRUB_GFXPAYLOAD" parameters would solve the problem. Not only did it not help with the resolution, it always prevented a console from showing up in the VM - I'd have to putty to fix things.

For me, the only solution that worked was to actually use the old grub modes, that is, I made sure I commented or deleted out all references to "GRUB_GFXPAYLOAD" and then, in /etc/default/grub I edited the

GRUB_CMDLINE_LINUX=""

line to say

GRUB_CMDLINE_LINUX="vga=0x319"

which is the code specific to 1280x1024 (by some color depth that didn't matter much to me). Then I ran

sudo update-grub

(not grub2; that'll work, but it gave me an init screen and then a warning so update-grub is more direct) and restarted and now I got a nice big console with no need to putty.

share|improve this answer
    
This worked for me! Thanks! –  Roy Rico Oct 26 '10 at 2:29
add comment

Add this to /etc/default/grub:

GRUB_GFXMODE=1024x768

Then run:

sudo update-grub2
share|improve this answer
1  
I tried that and it had no effect. Besides, I believe GRUB_GFXMODE only applies to the GRUB console, not the Linux console. –  user21841 Dec 26 '09 at 16:34
add comment

I use vmWare in WinXP + ubuntu 9.10. This may not apply to MAC.

1) In the vmWare's "Virtual Machine Setting", change Maximum resolution of any one monitor to my desire resolution.

2) In ubuntu 9.10, change the screen resolution via MainMenu-> System-> Preferences -> Display

I didn't make any change to grub.

alt text

share|improve this answer
3  
He's talking about the console, there is no Main Menu etc –  Blorgbeard Dec 23 '09 at 20:24
    
@Blorgbeard: +1. step 1 sounds reasonable though. –  quack quixote Dec 23 '09 at 23:32
    
VMWare Fusion doesn't have the "Maximum resolution" option. Besides, the VM isn't running X Windows so unfortunately your solution won't work. But thanks for posting! –  user21841 Dec 26 '09 at 16:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.