Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My laptop has two USB ports, but one is broken, so I use a USB hub in the other good USB port. In that USB hub, I use a mouse and keyboard. Suddenly, that USB port doesn't detect the mouse and the keyboard (even with the light of the hub is on), and the only solution that I found is restarting the laptop. But just some minutes and the keyboard and mouse goes undetected again...

Is there some method, software, etc. to "restart/repair" the USB port without restarting the PC?

share|improve this question

7 Answers 7

up vote 4 down vote accepted

If you have no power supply added to the USB hub, check if that helps. May be the laptop has not enough power on the USB, some older laptops had not the full 500mA.

share|improve this answer
    
Interesting! How I can check that voltage? –  Click Ok Dec 18 '09 at 0:09
1  
Powering a mouse and a keyboard via the USB port should not be a problem. I really wouldn't worry about that. –  Paul Lammertsma Dec 18 '09 at 10:56
    
Some computers show the voltage in their driver settings. Regarding the power consumption - or the problem - try finding the combination that brings trouble by using only one of the components, e.g. only mouse without the hub and the keyboard and if that works use only the keyboard and so on. Alternatively you can check if you have a power supply that fits to the hub, e.g. on my hub I the disk did not work and I found a 5V power supply that had the same +- combination and plug and now it works. Again: My old Dell Laptop produced only 300-400 mA. –  Thomas Dec 18 '09 at 11:22

None of the answers quite answer the title question.

How to “restart/repair” a USB port?

There are three ways to "restart" a particular USB port:

  1. Reboot the computer. Or ...
  2. Unplug, then re-plug, the physical device connected to the port. Or ...
  3. Disable, then re-enable, the USB Root Hub device that the port is attached to.

In Windows you'd do (3) through the Device Manager or via the devcon.exe utility.

The reason these are the only methods is due to the USB handshaking protocol, which is initiated by the USB device when it's plugged in, not by the controller. This causes problems like being unable to remount a USB flash drive after you've Safely Removed it. But cycling the USB Root Hub device causes all the devices attached to that hub to reinitialize themselves. (The unfortunate side effect is that it causes all devices attached to that hub to reinitialize themselves, which could be problematic if you have other devices on that hub which are in use.)

share|improve this answer
    
This is THE answer –  pratnala Mar 12 '13 at 9:43

You should look at NIRSOFT's USB Device view (http://www.nirsoft.net/utils/usb%5Fdevices%5Fview.html). I have used this to fix a system that had a disconnected U3 USB drive still mounted preventing anything else in the port being recognized.

share|improve this answer

I had issues with windows 7 dropping the USB mouse driver and reinstalling the mouse driver (most of the time) which was annoying as hell.

I tried all kinds of things to fix the problem, driver updates, clean boots, tech support phone calls, internet software voodoo, but in the end I only had to reset my USB ports.

I did this by turning the computer off, unplugging all usb devices, removing the laptop battery and AC power supply, and finally holding down the power button for 30 seconds.

This fixed a problem that I must have spent at least 20 hours trying to fix, give it a try.

share|improve this answer

Can you check your event viewer for any obvious errors in the application or system logs?

I don't know what the problem is at this point, but you should inspect the drivers installed. Are they Microsoft default input drivers or custom drivers? You might need to reinstall the drivers. It could be possible that the instance of the drivers is failing.

Also try inspecting the drivers after plugging in the device. You might see a resource conflict or some other warning in Device Manager.

Since the problem is occurring for two different devices, I think it's less likely a hardware failure on the mouse or keyboard.

The failure is definitely on your laptop.

share|improve this answer

Go to task manager and you will find a warning label on the device you are having problems. Just unplug your device and put into another computer or laptop. If it works on other computers it's definitely a problem with your USB port. Try replacing it, contact experts and change it. Try it and it will work definitely. If you find problems please change your Motherboard. Please don't buy a new one because the device has no problem. Hope This Helps!

And if any of that didn't work try USBDeview, it lets you view all installed/connected USB devices on your system. You can read more about it on it's download page.

share|improve this answer
  1. Go To "Device Manager"(open Control Panel in "Start Window")
  2. Go To "Universal Serial Port controllers"
  3. Look for "Exclamation Point" on one or more of the controllers
  4. (right click mouse)Disable, then(right click mouse) Enable
  5. Done!!
share|improve this answer
    
Basically the same answer as quack quixote already gave –  nixda Jun 8 at 8:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.