Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't get port forwarding to work now that I am using windows 7 (64-bit). I am using a wireless connection (no wired connection available). I have the ports forwarded (IP has been double checked, router settings are confirmed), there is an exception for all of the programs in question in windows firewall, and in the resource monitor windows lists the ports as available, not restricted, and yet when I either use a specific program (ie utorrent, DC++, Command & Conquer 3) or check using firefox, the port reads as closed. How do I get the port forwarding to work?

share|improve this question
    
It may be related, but I can't seem to get my network to go above 5% utilization, even if I try to watch videos (which stutter horribly). Streaming a 5 min video (paused, to build up the whole thing in the buffer) takes over 30min. –  Elliot Dec 18 '09 at 21:45
    
The speed issue is fixed; it was not related. –  Elliot Dec 19 '09 at 17:55

3 Answers 3

Things to check:

First, open up Resource Monitor and look under Networking. It will show you three things: 1) Services using ports 2) Open Connections 3) ports being listened on.

Therefore you should be able to see the request as Firefox is making it and see which ports (local and remote) are involved and see if the request is being allowed through in the listening port area. (there should be a firewall status).

Second, always double check with another system. I recommend starting up a virtual machine (something small like Knoppix or PuppyLinux) and setting it to bridged-mode first, then NAT. If the port is open in NAT and not bridged, you know it's Windows 7. You can, of course, also connect a second laptop to the same cable and see if the port is open that way.

Third, try turning off all security software, including Windows Firewall, Norton, etc, AND Windows Defender (or Security Essentials if it's installed). Assume any security software, native or third-party, are doing their job too well before assuming Windows 7 is slick enough to block ports on its own.

share|improve this answer
    
As far as the resource monitor is concerned, the ports are opened, but nothing that tries to use them gets through. Attempts with AVG killed, firewall off, all negative. –  Elliot Dec 19 '09 at 20:22

There may be two firewalls that interfere: Windows and the router. Both should be disabled for testing. You may use the suggested canyouseeme.org for testing.

If the tests are positive, meaning the ports are open, try temporarily turning off UAC to see if that's related to the problem.

If the ports are still reported as open but the programs can't use them, then there's a problem with the port forwarding definition. Some products need more than one port open, or of different types (TCP/UDP).

I suggest that for a more detailed answer, you should include screen captures of the router's port-forwarding page(s), so we can comment.

share|improve this answer

Did you check your router to make sure the port forwarding rule is enabled? I run AVG Anti-virus on Windows 7 Home Premium 64-bit (retail) and have no issues forwarding ports on my Linksys WRT54G or WRT160N.

share|improve this answer
    
I live with a few other people, one of whom owns the house and is an IT guy, and he is responsible for the net admin duties, and he says the port forwarding is fine up to my computer. –  Elliot Dec 18 '09 at 21:37
    
How do you know the ports are being blocked on your computer? Try canyouseeme.org and see what that says. –  rodey Dec 21 '09 at 14:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.