Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This problem has been occurring quite frequently recently and I can't seem to find a way of preventing it. Whenever I perform an action with yum such as to install or remove software, it appears to execute successfully but then I'm unable to move onto the next yum command

For example, I executed yum remove skype, it appeared to remove ok, but next when I try to yum search skype it appears that yum is still processing, and I have to manually kill that process via kill 1234 (or whatever the PID is)

My output is as follows

[root@nevada james]# yum remove skype
Loaded plugins: presto, refresh-packagekit
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package skype.i586 0: set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

 Package        Arch          Version                  Repository          Size
 skype          i586            installed           24 M

Transaction Summary
Remove        1 Package(s)
Reinstall     0 Package(s)
Downgrade     0 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Erasing        : skype-                                 1/1 

  skype.i586 0:                                                    

[root@nevada james]# yum search skype
Loaded plugins: presto, refresh-packagekit
Existing lock /var/run/ another copy is running as pid 3639.
Another app is currently holding the yum lock; waiting for it to exit...
  The other application is: PackageKit
    Memory :  79 M RSS (372 MB VSZ)
    Started: Fri Dec 18 08:39:18 2009 - 00:01 ago
    State  : Sleeping, pid: 3639

Kernel version :

Any ideas how I can prevent this behaviour?


share|improve this question
I am having the same problems! – Lazer Feb 27 '10 at 5:47
up vote 1 down vote accepted

Kernel version :
Any ideas how I can prevent this behaviour?



# gnome-system-monitor

(actually, I don't think it HAS to be root level access, but that's how I usually run it.)

On the Processes tab, select the PackageKit entry and click End Process.

If there are multiple PackageKit entries (such as plugins), repeat that step.

Now run the yum command[s] you desire and yum should be able to get the lock before PackageKit's update check starts again.

Of course, if you've never installed that tool, first you need to run

# yum install gnome-system-monitor

while PackageKit does not have the yellowdog update monitor's files locked. I think that tool works much better (for this purpose, anyway) than kill or killall.

share|improve this answer

PackageKit is the graphical tool that alerts you when updates are ready. It's triggered by the "refresh-packagekit" plug-in (see the second line of your quote). Not sure if you can disable it, but just waiting a few moments should avoid the issue.

Are you using a graphical desktop environment (like Gnome or KDE)? If so, look for the PackageKit icon in the notification area (in Gnome, it's in the top-right by default). Have you ever seen a pop-up saying there are updates ready? This is PackageKit. It needs to be refreshed each time something happens with yum so that it can display correct informations.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.