Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am installing Fedora 9 to a PC (specifications at the bottom) and have had a lot of trouble with it recognising the hard drive. To get the Fedora installer to recognize it in the first place I had to pass "ata_generic.all_generic_ide=1 pci=nomsi" to the kernel, after which it installed OK.

However, now when I boot the installed OS, I get a "could not find filesystem '/dev/root'" error. I tried passing the same arguments to the kernel at boot as I did when installing but to no avail.

I have tried using the default LVM layout and defining manual ones but it made no difference. There is no option in the BIOS to enable AHCI or anything like that, in fact the BIOS is very limited in most respects. I can get into the system by using the installation CD in rescue mode (with those extra kernal parameters) but I'm not sure what to do once in there...

Unfortunately using a more recent version of Fedora or even another Linux distribution altogether isn't an option becuase of outside constraints - which is annoying since I know for a fact Ubuntu works fine on this setup.

I have not been using Linux that long, so treat me like an idiot - I am one. Any help would be greatly appreciated, thanks!

System spec:

  • Intel Atom Z530 CPU @ 1.6 GHz
  • Intel US15W chipset
  • 1 GB DDR2
  • 160 GB SATA harddisk (Samsung HM16HI)
  • 1000 Mbit/s Ethernet port
  • Phoenix BIOS


I tried passing the same parameters as I did during installation, but it didn't help. I've tried installing it with and without LVM. With LVM the error I got referred to the volume group, and without it just referred to the root location - both symptoms of the same problem I suspect.

The device I'm installing on (a FitPC 2 for anyone who's interested) comes pre-installed with Ubuntu, which I had working - so I'm fairly certain it's not a hardware problem. I'm quite interested in trying virtualisation anyway, but the Atom isn't all that powerful as you pointed out - and I don't really have the time to investigate it.

I might try patching the kernel later as some things might have been added for this since my version (2.6.24 I think).

share|improve this question

migrated from Dec 18 '09 at 9:53

This question came from our site for professional and enthusiast programmers.

This isn't really a programming related question? – vrutberg Dec 18 '09 at 9:51
belongs to – Gregory Pakosz Dec 18 '09 at 9:51

Have you tried passing the same parameters to the kernel when trying to boot as you did when getting it to recognise the drive during installation (depending on what is giving the error, Grub or Fedora itself)?

When you say you tried defining your own partitions, you did mean without LVM didn't you? If not give it a try.

If you really need Fedora 9, could you use another distro and then use a virtual machine (although you don't have much horsepower in your atom...)? At any rate, I think it would be a good idea to at least try another distro to rule out hardware problems.

share|improve this answer

You must log in to answer this question.