Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed a Windows 7 Enterprise on a Virtual Machine (Microsoft Virtual Server 2005). The Windows is activated.

The first thing I found was this, but I am definitely sure my timezone and time and date information is correct.

Still I get a Code 80072F8F Windows Update encountered an unknown error. When trying to "Check for updates".

I know about this KB article from Microsoft. I also know about this question on ServerFault. I tried everything there to no avail.

Any other suggestions?

share|improve this question
up vote 5 down vote accepted

Your problem might be that the Microsoft Windows Update web server SSL cert is untrusted due to a missing root certification authority (CA) certificate.

See this article: Windows root certificate program members
where you can manually download and install all third-party root certificates that are distributed via the Windows Root Certificate Program.

share|improve this answer
Ok, that did the trick. Although the article you link to doesn't apply to Windows 7, after installing the root certificate update, Windows Update started working again. Thanks! – fretje Dec 18 '09 at 12:19

For me the issue was the time on the server was not correct. After enabling syncing with an Internet Time service under the clock settings, I was able to run windows update normally.

share|improve this answer

You must log in to answer this question.

protected by Jeff Atwood Nov 18 '10 at 9:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .