Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am getting the error "The data area passed to a system call is too small. (Exception from HRESULT: 0x8007007A)" when trying to create a scheduled task on a particular windows machine.

The problem description is identical to that described in this Microsoft KB article

I followed their steps to resolve:

  1. Stopped the task scheduler service (right-clicked "Task Scheduler" in the Services window from Control Panel and selected "Stop").
  2. Restarted the task scheduler service
  3. Waited 15 minutes
  4. tried to schedule the task.

But the error is persisting.

To give more context of how we are creating these scheduled tasks, they are actually generated automatically from a configuration script (we run the script each time we wish to make a change). Each time this happens, it deletes all of the existing tasks and creates new ones.

I don't know what else to try.... but surely there is some way to "reset" the task scheduler... How can I stop this error from happening.

share|improve this question
add comment

2 Answers

After having tried the Microsoft KB work around that didn't help, I stopped the tasks scheduler service then opened a command prompt in C:\Windows\Tasks and typed dir /a.

It listed all my scheduled tasks plus two tasks that were not shown in the Tasks Scheduler UI (for my part two jobs named "At1.job" and "At6083.job").

I just deleted these two files from the prompt, then started the tasks scheduler service, and finally opened the tasks scheduler UI. From this point I could again create tasks normally.

share|improve this answer
    
Thank you Frederic, yours is the only complete answer I have found on many forums. Clearing the task manually is the only thing that works. Richard –  user86326 Jun 17 '11 at 14:41
add comment

I did two things which appeared to solve the problem - not sure which one actually fixed it:

  1. The KB article says to "To work around this behavior, stop and start the task scheduler service, wait for 10 to 15 minutes, and then schedule jobs."... I suspect what they should have said was "Stop the task scheduler, wait for 10 to 15 minutes, then start the task scheduler" (which is what I did)

  2. I found some erroneous .job files that it was complaining about in the log file (C:\Winnt\Tasks\SchedLgU.Txt):

"MorningPull.job" () 18/12/2009 10:32:09 ** WARNING ** Unable to load task. The specific error is: 0x80041313: The task object version is either unsupported or invalid.

So I also deleted this file. But that file had been there for a long time, so I suspect it was #1 fixed it but I don't have a way to confirm now.

share|improve this answer
add comment

protected by studiohack Jun 17 '11 at 14:44

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.