0

I've two virtual machines in virtual box which I've configured with quagga. I'm trying to do a ping between them but I don't get response. Here are the zebra, ospf and bgp files:

Router 1:

!
hostname router1
password zebra
enable password zebra
!
interface eth0
 ipv6 nd suppress-ra
!
interface eth1
 ip address 192.168.6.1/24
 ipv6 nd suppress-ra
!
interface lo
!
ip forwarding
!
!
line vty
!

-

!
!
hostname ospfd
password zebra
log stdout
!
router ospf
 ospf router-id 192.168.6.1
 redistribute connected
 redistribute bgp
 network 192.168.6.0/24 area 0.0.0.0
!
line vty
!

-

Router 2:

!
hostname router2
password zebra
enable password zebra
!
interface eth1
 ip address 192.168.5.1/24
 ipv6 nd suppress-ra
!
interface eth2
 ip address 192.168.6.2/24
 ipv6 nd suppress-ra
!
interface lo
!
ip forwarding
!
!
line vty
!

-

!
!
hostname ospfd
password zebra
log stdout
!
router ospf
 ospf router-id 192.168.6.2
 redistribute connected
 redistribute bgp
 network 192.168.5.0/24 area 0.0.0.0
 network 192.168.6.0/24 area 0.0.0.0
!
line vty
!

-

!
hostname bgpd
password zebra
log stdout
!
router bgp 2000
 bgp router-id 192.168.6.2
 network 192.168.6.4/24
 network 192.168.5.0/24
 redistribute connected
 no synchronization
 redistribute ospf
 neighbor 192.168.6.1 remote-as 2000
 neighbor 192.168.5.2 remote-as 500
!
line vty
!

For now I'm just testing these two routers so bgp is not used because they are in the same AS.

When I try to ping from router 1 to router 2 I get nothing. When I try to ping from router 2 to router 1 I get "Destination Host Unreachable"

If I look at ifconfig the IP addresses are correct. Why I'm not able to ping?

Thank you!

1 Answer 1

0

Please add option "multicast" to all interfaces in zebra.conf because OSPF use multicast, then restart both zebra and ospfd.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .