Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

It used to be that Spotlight would figure out math operations for me (for example, if I typed 5 + 3, the first Spotlight result, before any located files or other search results, would be the answer). For the last few weeks, it hasn't anymore - if I type a math operation, it just finds a bunch of documents.

I'm running Mac OS X 10.5.7. UPDATE: So far I've tried, based on the suggestions below:

  • Deleting the Spotlight preferences.
  • Setting defaults write CalculationEnabled -bool YES
  • Opening up the Calculator app and confirming that it's still in its default location.
  • Forcing Spotlight to reindex my hard drives.
  • Re-installing the 10.5.7 combo update.
  • Rebooting after each of the above.

Unfortunately, nothing has worked - Spotlight still doesn't solve the operations.

share|improve this question
I can still run Calculator manually - and it's still in the default location (/Applications). – Charles Jul 19 '09 at 12:55
5+3 is an operation on two numbers not an equation – bandi Jul 19 '09 at 18:46
You're right, of course. Corrected to remove references to equations. – Charles Jul 19 '09 at 20:38
+1 I didn't know that my Spotlight does this! Thanks. I mean, thanks and I hope you solve your problem. – Dan Rosenstark Sep 3 '09 at 9:33

open up a terminal and try

defaults write CalculationEnabled YES

If that doesn't work, you might need to remove from your user preferences folder, and then re-boot. This will remove any exclusions you have set up though, so you will need to manually put them back.

If that doesn't work, open up calculator and use it to perform a calculation. That as worked for some people.

There were some problems with this caused by the 10.5.6 update, so if you have recently upgraded, or the steps above don't work. You might want to download the combo update for you current version and reinstall it.

share|improve this answer
I deleted the preferences file, added the CalculationEnabled preference, rebooted, and let Spotlight chug away for a while. Still no luck. I'm running 10.5.7, do you still think there is value in reinstalling the 10.5.7 combo update? – Charles Jul 19 '09 at 12:58
It might be worth a shot, some people have reported it as solving the problem when they upgraded from 10.5.5 to 10.5.6, so you might have the same problem. – Bruce McLeod Jul 19 '09 at 13:05
Also try opening up calculator and using it. That has fixed it for some people. – Bruce McLeod Jul 19 '09 at 13:12
I had opened up Calculator before (that's how I've been doing my simple math queries now that Spotlight isn't working) and it had no effect. Unfortunately, reinstalling the 10.5.7 combo update also didn't work - it's still not working. – Charles Jul 19 '09 at 13:29
oh crap ... I'm fresh out of ideas ... – Bruce McLeod Jul 19 '09 at 13:34
up vote 3 down vote accepted

Installing Snow Leopard fixed the problem - hopefully it doesn't recur, since I never figured out what caused it in the first place!

share|improve this answer
That's too bad, I'd advise looking into Console and checking for file permissions (chmod / chown) as well. Two of most common methods and issues that I couldn't see advised anywhere else here. – cregox Apr 23 '10 at 20:26

Spotlight does this by "feeding" The Calculator program must be in a folder being checked by Spotlight in order for this function to work.

Make sure Spotlight can find by checking Spotlight Preferences.

Or perhaps you moved to another location, in that case you might just want to move it back to Applications.

P.S. Your problem is not uncommon, I've seen this question asked before. So +1 to your question.

share|improve this answer
Calculator is still in the default spot - when you say to make sure Spotlight can find, what do you mean? I can't find anything on either of the two tabs for Spotlight Preferences that have anything to do with Calculator app. (Spotlight does find the Calculator app just fine when I do a Spotlight search for it, though.) – Charles Jul 19 '09 at 12:56

Maybe re-indexing Spotlight might do something? Doing this now, have the same problem. The easiest way to re-index is to go to Spotlight prefs., go to Privacy, select your HDD, add it. Then close the prefs., open them again and remove your HDD. Spotlight should now be re-indexing it. Alternatively, for you bash-shell fiends, you can use the command sudo mdutil -i on /

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .