Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I relocated my user profile onto another partition, and now Win7 search doesn't provide any results when I search "Documents". If I search the drive, or my profile directory, I get results, but if I open up Documents and search it provides no results.

A bug perhaps?

share|improve this question

5 Answers 5

How long since you migrated? The index can take minutes to hours to do its initial population. I frequently work with customers who have just started their computer for the first time, and the index contains nothing at that point... but when I talk to them a day or so later, it's working perfectly.

If you just relocated your profile, my suspicion is that the index needs to be recreated.

share|improve this answer
    
It's been about a month. –  JoshRivers Dec 20 '09 at 21:20

Could it be that the service called Windows Search (Indexer) is disabled?

Here is how to enable it:

  1. Click on start, go to control panel.

  2. Open administrative tools, right click on services and click on run as administrator.

  3. Scroll down for Windows search service, check if it is started.

  4. If no, then right click on the service and click on start.

If that doesn't help, try to open the Search and Indexing troubleshooter.

share|improve this answer
    
Not this specific problem. Indexing works and is up-to-date...just doesn't work in the Documents context. –  JoshRivers Nov 1 '11 at 16:17

Verify that your 'Documents Library' (right click and check properties) contains the correct physical folder locations that you want it to include.

The Windows 7 'Documents' doesn't work in exactly the same way that 'My Documents' worked on previous versions of windows, now you can actually have several different locations contents displayed in the 'Library'. :)

share|improve this answer

maybe you need to configure the indexer to include the new path. click start and start typing "index" in the search box or go to system settings and open "Indexing Options". make sure the path you want to search is included.

OR go to the folder you want to search, search something and see if a yellow bar appears telling you that the search is slow becouse there is no index.

share|improve this answer

I noticed Windows 7 doesn't show system and hidden files in my notebook. Did you check files attributes and permissions?

You can also try to put a file in a folder, later type its name without any weird symbols to see what you'll get.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.