Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to stop X so I could install graphics drivers. First I tried with killall -9 X but X server just restarted. Then I tried init 3 but that didn't closed X. How do I close it?

share|improve this question

Just stop (as root) the process that respawns the X server:

# /etc/init.d/xdm stop

(yes, this is xdm even though you might be using something totally different)

share|improve this answer
@quack rollback since this is always xdm in gentoo. gdm and kdm are started by the xdm init script depending on the site configuration. – Benjamin Bannier Mar 24 '10 at 3:22
sorry about introducing the mistake. i think i went in to fix the code block formatting and got distracted. – quack quixote Mar 24 '10 at 3:28

Press Ctrl+Alt+F1 to get to the tty where the X server is running from and then Ctrl+C to kill the server.

Alternately, if X started an xterm for you, run top and find the PID of the process named "X". Then press k, enter the PID, press enter, press 2 and then enter at the "Kill with signal" prompt, and there you go. This will also work if your keyboard drivers are not set up correctly and therefore no input is accepted, you just have to use ssh to login over then network.

Alternately, press Ctrl+Alt+Backspace (this will only work with some configurations).

share|improve this answer
I used killall on X processes and then X just restarted, won't kill do the same? – Joe Dec 19 '09 at 1:10
It may, and if it does, you can go to another tty (for examply tty2 with Ctrl+Alt+F2) and install the drivers from there, and then restart X using killall. – marcusw Dec 19 '09 at 2:40
was stuck on the log in screen and couldnt figure out how to get out. Ctrl+Alt+F1 did the trick – Noah Passalacqua Jan 3 at 2:49

If you're booting with Grub, you can reboot & enter just the number 3 as a boot option, and it should boot into init level 3. I'm sure you can do this with the other boot loaders, but I haven't used anything but Grub in a while.

share|improve this answer

If X starts automatically during boot, and you can't get X to stop, you can:

  1. Reboot and when it is booting, press i to enter interactive boot mode.
  2. Tell it to start services until you get to the one that starts X (usually either local or the name of the display manager you are using, finding this out may take some trial and error), and then press 2 to skip the service.
  3. When you make it to the login prompt, login as root and install your drivers.
  4. Reboot or just run "/etc/init.d/{service_skipped} start" and that should start your login manager or X.
share|improve this answer

If you don't can stop x. Then you could change driver name "vesa" or "nv" for "master of linux". This will crash you xorg.conf. Now, reboot your pc.

Login and install with sudo sh

And automatically configure your new xorg.conf.

Reboot again, and problem resoult.

Im sorry my English. I don's speak very well. Im spanish from Buenos Aires, Argentina.

I have same problem and resolv to this way.

share|improve this answer

You must log in to answer this question.