Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install a Logitech QuickCam Pro 9000 webcam to Windows 7 64-bit.

If I do it without using the Logitech drivers but instead the Windows Update ones, the camera works with low frame rate and without face tracking and all other bells and whistles that it's full driver provides.

The moment I install the latest official Logitech driver, the problems begin:
Camera works fine, until I decide to go to audio settings of the LWS panel or Windows'. Then LWS freezes and with it everything that tries to output audio. I am not able to open Playback/Recording devices window (it just doesn't appear) and system gets unstable and slow with LWS.EXE process not been able to close forcefully.

If I reboot and forget the camera connected, this situation continues and system gets unstable from the beginning.
If I reboot without the camera connected, everything works fine until I connect it and try to do something with audio settings of Windows or LWS panel.

I should note, that until the freezing occurs, camera works as expected, with full frame rate, face tracking and everything that is expected to do.

The soundcard is the ASUS SupremeFX II of the ASUS Striker II Extreme motherboard.

Any ideas of what is causing this or what else to try so I can make it work as advertised?
Thank you.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I've decided to become a bit more aggressive so I've disabled the microphone of my webcam and voila!

Logitech driver works ok, no freezing no problems whatsoever. I've using an external mic, well I will have to live with that and continue hopping that one day Logitech will fix the problem in a future driver.

Disabling mic in Pro 9000

share|improve this answer
    
Found any other remedy m8? I had the same problem until I figured out that the f@#$ camera was the problem during a clean win7 install... –  FailedDev Oct 17 '11 at 11:16
    
The version of drivers that came after I posted this, fixed any problems I had. –  Saxtus Oct 18 '11 at 3:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.