Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to access with EventViewer (from a Windows XP Prof) to a remote machine with Windows 7 (Seven).

Before I started the Service "RemoteRegistry" I received an "Access Denied". After started the service I can connet to the machine Log (in EventViewer app) but when i clik on any log as "Application" or "Security" I receive a "privilege" error.

Could someone help me, please?

share|improve this question

migrated from stackoverflow.com Dec 19 '09 at 8:50

This question came from our site for professional and enthusiast programmers.

2 Answers 2

By default when trying to carry out tasks that require elevated privileges (such as this one) you need to connect to the remote Windows 7 system using the credentials of the explicit local Administrator account on that system, or the credentials of a member of the Domain Administrators group if its part of a domain. UAC prevents other users, even members of the local Administrators group, doing this. What account are you using on the XP Pro machine to authenticate the connection?

This article on MSDN about UAC explains this in detail.

share|improve this answer

I'm using, onto Window Seven machine, an account that belongs to the local Administrator group. I am in a Workgroup and not in a domain.

The account I use onto the Windows XP Pro belongs to the Administrator group too and the credentials onto the Windows XP Pro and onto Windows Seven are the same.

Probably Do I have to give some more privilege to the Seven user?

share|improve this answer
    
No using a member of the Administrators group is not sufficient, you have to use The Administrator's account. You can disable\change this particular UAC behavior, or disable UAC completely to work around this. The reason is to do with automatic elevation which is active for The Administrator but not for members of the Administrators Group. –  Helvick Dec 19 '09 at 18:54
    
you are right. Thanks for your help –  robob Dec 20 '09 at 10:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.