Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed MonoDevelop on my mac, and I like it. But I don't like the German translation and I can't find any place in the menus where I could change the interface language.

Any ideas?

share|improve this question

migrated from stackoverflow.com Dec 19 '09 at 18:46

This question came from our site for professional and enthusiast programmers.

6 Answers 6

On the Mac, applications try to follow the system wide language preference provided that they have the corresponding localization. So, the easiest way to change the menu language in MonoDevelop without changing the system preferences is to remove or rename the German localization so that the app will fall back to using the US menus.

To do this: control-click the icon for the MonoDevelop application and choose "Show Package Contents". Then navigate to the Resources subdirectory, find German.lproj (or something similar - I don't have MonoDevelop) and rename it. This will do the job.

share|improve this answer

You'll need to run the program with the appropriate environment variables to tell gettext which translation to load/use. Here is some documentation on gettext environment variables.

LANGUAGE=en_US would be a good place to start, unfortunately I don't have an OSX machine to verify, let us know what works.

share|improve this answer

The only thing that helped me was using the following AppleScript and making it an applet:

do shell script "LANG=en_US.UTF-8 open /Applications/MonoDevelop.app"

This took me two hours to find this out :-(

-Matthias

share|improve this answer

MonoDevelop 2.4 has an option in Preferences to override the GUI language.

share|improve this answer

Reading this mail from Miguel, you have to change the LANG environment variable LANG to LANG=en_US.UTF-8. I'm not familiar with Mac, but the linux terminal way would be prepending LANG=en_US.UTF-8 exactly before the command which changes this variable for the executing application.

share|improve this answer

cefstat is right, the actual path is Contents/MacOS/share/locale/**

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.