Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am runing ubuntu 9.10 and the latest version of skype but I have problem with webcam. When I trie the webcam with cheese it works fine but when I try to use the web on skype , skype crashes. can any body help me

share|improve this question
up vote 2 down vote accepted

Skype cannot directly interact with video4linux. You need to load an extra library (v4l1compat.so) for the compatibility layer:

# LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

Maybe you need to adjust the library path for your setup.

To make this permanent just add this variable to /usr/bin/skype: add

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so; export LD_PRELOAD

e.g. on the 2nd line there.

Maybe you also want to report this in your distribution's bugtracker.

share|improve this answer
    
Thank you man, it works. but please tell me can make this permanent change. – Ayoub Dec 19 '09 at 22:33
    
Man, you are the best! Does this solution works for any video conferencing application? – SpaceDog Dec 21 '09 at 21:32
2  
Where do you add this line? /usr/bin/skype is a binary file, no? – endolith Apr 15 '10 at 23:47
    
Where should i add this lines? – Eray Jun 18 '11 at 21:21

The question is old but the problem still exists. As honk says, setting LD_PRELOAD to the v4l1compat.so library works.

On my 64-bit ubuntu 12.04, this worked:

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype

I have a 32 bit skype, so the library should match that.

I want to launch skype with a panel icon. I put this in the command field:

bash -c "LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype"

This avoids creating a separate script file. Without bash however, it does not work.

share|improve this answer

I couldn't add to the /usr/bin/skype file either (it is a binary file). Anyhow here is my workaround:

1) in my home folder I made a file (using gedit) that contained -

#! /bin/bash

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype 

2) then added an application link to my menus -

bash /home/yourusername/skype_with_video.sh

(the Skype icon should be in the /usr/share/icons/ folder for the link)

Not elegant, but it works.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .