Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a machine running Windows XP that, within about 5 minutes of powering on, will become almost unusable for 30 seconds to 5 minutes. The hard drive light will stay solid, and UI elements become mostly unusable. For example, clicking "Start" may only elicit a response after 2 minutes. Eventually, the hard drive light will go off, and the machine will return to normal operation.

The machine is a AthlonIIX2-250. It uses an AMD 770/SB710 chipset motherboard of high quality. I have tried (not necessarily in this order):

  • Re-installing Windows
  • Replacing the Motherboard
  • Replacing the hard drive SATA cable
  • Replacing the RAM
  • Updating the drivers
  • Replacing the wireless card with a different brand and chipset

I have tested the hard drive with both Western Digital Diagnostics and Spinrite, and neither have indicated any errors. I have run numerous RAM tests using Memtest86+. Again, no errors. I have used a power supply tester on the system, and there is no indication of problems. The problem appears to be aggravated by wireless network access (the system freezes more frequently or sooner after booting), but a wireless network connection need not be established for this to happen. The problem happens less frequently using the integrated NIC, but still happens. The Windows Event Viewer shows nothing unusual. The problem occurs in Safe Mode and also in Safe Mode With Networking. The problem also occurs on bare minimum re-install with no third-party drivers loaded except for the AMD AHCI driver supplied by the motherboard vendor.

EDIT 5: Summary above changed to reflect help so far.

Just some background on me in case it helps: I have built and repaired thousands of PCs and servers over the last 7 years. I run my own Linux-based mail server. I use Linux on my usual desktop. I own a Mac Mini. I own two Windows XP machines. I have some experience with Windows Server. I have built and configured networks for about 20 small and medium businesses from scratch (and inherited countless others). I would like to think I have a fair degree of technical competence, but this one has me beaten.

share|improve this question
    
What do the event logs say? –  phoebus Dec 20 '09 at 4:10
    
If you load up using a Linux Live CD, do you get the same result? –  Zurahn Dec 20 '09 at 4:15
    
Does it occur in safemode? –  thegreyspot Dec 20 '09 at 5:10
    
I'll try the Linux Live CD, but I don't think that will enable me to reproduce the problem since it won't be installed on the hard drive. –  Solaris Dec 20 '09 at 5:36
    
I'll boot into Safe Mode with Networking and see how it goes. –  Solaris Dec 20 '09 at 5:45

6 Answers 6

To check the issue, I recommend to use tools from SysInternal. You can check which process takes most of CPU time with Process Explorer.

And there are three reasons maybe caused the issue:

  1. Memory swap. Physical memory maybe too small when a process eats memorytoo much. The OS has to use disk to act as virtual memory.

  2. Dead lock of processes.

  3. Virus.

share|improve this answer
    
The system has 2GB of RAM and is running on pretty much a fresh install. I sincerely doubt it is a virus or lack of memory. As for a process deadlock... well that's possible I suppose. The question is which processes. –  Solaris Dec 20 '09 at 4:52
    
Disabling the Java Quick Starter appears to mitigate the problem to a certain extent, but definitely not completely. Bizarre again. I thought maybe jqs.exe was causing a deadlock, but it would sometimes occur without jqs.exe running. –  Solaris Dec 20 '09 at 12:23
    
Process Explorer is an excellent tool for diagnosing issues like this. You should be able to determine what process is taking control of your CPU as well as what is causing your HD to churn. It will even let you kill the process that is causing the problem and regain control of your system. I would look into the WMP Network Sharing. I have had issues with this process taking over my machine in the past. You can turn it office using the Services control panel. –  Zooks64 Dec 20 '09 at 14:28
    
Thanks gadzooks. I'll give that a try. The CPU use isn't spiking at all during these HDD churns, so if Process Explorer shows what is using all the I/O time, I'll give that a shot. –  Solaris Dec 20 '09 at 15:27

I would still lean towards HD unless you've shown otherwise. Since it sounds easy to reproduce, I would try installing windows on a spare hard drive and see if it still happens.

Some other things come to mind...

  1. Have you done any special customization to the windows setup? (prefetch, page file size, etc?)
  2. Do you have another processor to try?
  3. What happens when you remove / disable anything not absolutely necessary?
    • Remove extra cards {modem, NIC, Wireless NIC}
    • Disconnect unnecessary internal connections {DVD, CD, USB headers}
    • Boot: Does the problem reproduce itself?
      • If not, you know it is one of the above, and you can re-add each until you find the culprit.
      • If so, you know it is something you haven't disconnected, or it is software. You may be down to CPU, new HD, or Video card, or something 'weird' going on with the slipstreamed XP disc being the issue?
  4. Finally, if nothing works... take the computer into a field and go all Office Space on it. ;)
share|improve this answer
    
I use a disk with some drivers slipstreamed that may be causing an issue, though this would be the first time. I don't have another processor to try sadly. –  Solaris Dec 20 '09 at 5:38
    
(FYI... I can't comment on other threads yet, but this is in response to gadzooks64 suggestion), If you're able to get Procexp up and running before anything else, you will need to add the IO Read/Write columns and sort by those to spot the biggest impact. –  mpeterson Dec 20 '09 at 15:58

Although the timeframe isn't as long I've seen this sort of lockup with the hard drive light on from the ICHR9 drive controller that's on so many motherboards. I've never had it happen on a new board, only after a few months. As it gets worse it will lead to periodic BSODs.

This box used to suffer the lockup bit and then started BSODing. I finally slapped an add-in drive controller in and ran the main drives off it (the optical is still off the MB) and I haven't seen a lockup nor a BSOD since I did that. No other hardware changes, the only software change was the addition of the driver for the new card.

The miserable quality of the support software that comes along with the ICHR9 makes me suspect they were as sloppy with the hardware. The program for configuring the system once the OS is booted can take 20+ seconds to refresh the drive status--and it will do so as part of the screen repaint, including as a result of any click. At least you don't have to run that, but the driver that runs it is another matter--the version that shipped with the board leaked about 100,000 handles/hour. This would eventually kill Windows or eat up so much memory that you had to reboot. A later version of the driver at least fixed this problem.

share|improve this answer
    
Unfortunately this is not an ICHR9. It's using the AMD 770/SB700 Chipset. I've certainly never had issues with it before, but I'll see if a BIOS update or driver update is available. –  Solaris Dec 20 '09 at 4:51
    
Correction, it's using an AMD SB710 chipset. That's a newer revision than I had been using, so I'll look into it more. –  Solaris Dec 20 '09 at 4:54
    
I've tried updating the drivers, that didn't help. I'll try moving the drive to AHCI mode along with a "System Repair" and see what happens. –  Solaris Dec 20 '09 at 5:37
    
Moving to AHCI didn't help at all sadly. –  Solaris Dec 20 '09 at 15:29

You say that direct cable-connection works much better than wired, no matter which wireless card is used.

Is it possible that the problem isn't hardware, but software that downloads a large amount of data, so that direct connection simply does it faster?

I would suggest :

  1. Making sure all installed software is fully patched
  2. Using a line sniffer to see what's happening during these periods (have it already up and waiting for the freeze to come). It might be simpler to use TCPView.
share|improve this answer
    
Freeze usually happens just after the network starts harrymc. –  Solaris Dec 20 '09 at 11:25
    
This seems logical if some software is waiting to pounce on it. Try maybe to start TCPView before starting the network. –  harrymc Dec 20 '09 at 11:29
    
I agree - start up TCPView this seems like something is trying to access the network and eventually times out. You mention elsewhere that you used a disk with some slipstreamed drivers so a reinstall may not be giving you the clean start you are expecting. –  jtreser Dec 20 '09 at 11:43
    
A fresh install from a plain Windows XP SP2 disk still displayed the same behaviour, even with only the AMD AHCI driver loaded. –  Solaris Dec 20 '09 at 15:28
    
Have you looked at the Event Log? –  harrymc Dec 20 '09 at 15:46

I've had a similar issue with my own computer, though not quite the same setup -- mine's an AMD 790FX/SB750 Asus mainboard (related to the afore-mentioned AMD 770/SB710 -- more features, same generation) running windows 7 release candidate 64-bit. With the hard-drive access light pegged, I would hear no noise from the hard drive (other than the usual healthy sound of the spinning platters, but no head movement at all) and be unable to load anything from the disk -- if taskmanager was already running, and thus in memory, it would work fine, but not otherwise. Hitting the reset button, the system posts just fine and I can get into ExpressGate without a problem -- and it loads and runs from the same physical drive. This all is running with the AMD AHCI drivers in windows, and the drive set to AHCI in the bios. Suspecting the AHCI drivers, I switched the bios setting to IDE, and have yet to see the issue pop up again so far. Is it just crappy AMD AHCI drivers, then, perhaps?

share|improve this answer

This almost sounds like an IRQ flood causing the CPU to spend all it's time doing essentially nothing. The first thing I would try is this. Pull every non essential card and wire. You've already replaced everything essential. You can also boot from a Live CD as another suggested. I would turn off all the hard drives in BIOS if you do. This would eliminate the drive subsystem.

I would even move the PC to another power source and use a different monitor/video card. This is essentially a shotgun approach, but if you can prove that the problem can be eliminated, then you know you've isolated it. Then you can start working back the other direction and add components back until you re-introduce the problem. Once you narrow it to the correct subsystem, you will know where to look.

Always remember in any problem, there is the trigger and the failure. It's the trigger you have to find and eliminate. It could be external. If it's physically connected, it's a possible factor. You may have to literally "think outside the box". Good luck

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.