Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 7 cannot discover any samba servers on my local network, I can navigate to them manually with \\server.

Solved (kinda)

share|improve this question
2  
I'm no Win7 expert but suspect that your network settings from Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings might help someone diagnose it? –  serialhobbyist Dec 20 '09 at 16:07
add comment

4 Answers

Rather than reduce the security offered by Windows, you can add this to smb.conf:

local master = yes
preferred master = yes

This will make your Samba server appear in the Windows 7 Network browser.

For added fun, you can also add

ntlm auth = no
lanman auth = no #the default is no.

but this will require you to add the

sec=ntlmv2
option to all of your authenticated Linux CIFS mounts, as it deactivates NTLMv1 auth.

share|improve this answer
add comment

This article might help: Get Vista and Samba to work.
(Although written for Vista, it also applies to Windows 7.)

If the cause for the problem is NTLMv2 authentication, this article describes how to make Windows 7 negotiate with Samba for a common authentication protocol.

share|improve this answer
    
Thanks, no change though –  Sam Dec 20 '09 at 22:49
add comment
up vote 1 down vote accepted

Solved

In the Advanced Sharing Settings (accessed through left panel in Network and Sharing Centre), Choose 'Enable file sharing for devices that use 40- or 56-bit encryption'.

Seems that samba doesn't support 128-bit encryption (or I haven't configured it to do so)

share|improve this answer
add comment

Make sure your Hostname of the system itself is the same as the hostname in ``smb.conf. There seems to be an issue where Windows clients can not see the samba server unless this is so.

So if your system hostname is different from what you want smb to show, change either.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.