Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For all my googleing it appears the best you can do is tell your computer not to use DHCP; I cannot find a way to do this at the Access Point level.

EDIT: This is not for port forwarding. This is for an internal mythTV server. Right now the DHCP server on the AP is set to assign IP's from 192.168.1.100 - 192.168.1.149. When I set a static IP outside that range on the computer that computer is unable to connect to the Internet.

I've done this before on my old Buffalo brand AP (may it RIP) without any problems. This seems to be a WRT54G2 specific issue.

share|improve this question

7 Answers 7

up vote 6 down vote accepted

From what I have found, it doesn't look like the WRT54G2 supports setting static IPs through the DHCP server. Depending on the version of the WRT54G2 you could load a 3rd party firmware such as DD-WRT onto the router to add these features. Here is a tutorial from someone who did it on a WRT54G2.

share|improve this answer
    
Seconded, I have a WRT54GL and it uses the same firmware. No static leases. I installed DD-WRT, too, and it has some nice other caveats as well. Just be very careful when flashing the firmware, as this is a very sensitive process. Be sure to read EVERYTHING related on the dd-wrt forums/wiki and follow the steps closely. –  Tobias Plutat Jan 24 '11 at 18:52

I agree with @Spooky. I'm assuming that you want to set static IP's for port-forwarding. You can set certain computers using the MAC Address (directly connected to the AP is best-case and easiest).

Or by setting the IP(s) Manually on the computer(s) outside of the normal DHCP Range (ie: DHCP set from 192.168.xxx.100 to 192.168.xxx.250, manually set the IP(s) from 192.168.xxx.50 to 192.168.xxx.99).

EDIT: Even if you set the IP manually, you will still need the subnet mask, gateway, and DNS IP's to connect to the Internet and the rest of your network. Check those settings to see if there is an issue.

share|improve this answer

I may be completely wide of the mark here, but when you say

When I set a static IP outside that range on the computer that computer is unable to connect to the Internet.

Are you also setting said computer to use a specific DNS server and gateway? It may be worth checking the DNS server and gateway assigned via DHCP and checking it's the same as what you're manually setting.

share|improve this answer

I dont have this model but a lot of routers let you assign a Static IP by MAC address. If this does not work, you have to set it in your PC.

share|improve this answer

Here's what it took to make this work:

  1. Set the static IP either in the GUI or in the text file
  2. Set the netmask to 255.255.255.0 OR 255.255.240.0 (the later works on the computer hooked into an Ethernet -> wireless bridge, the former is Ethernet straight to the Access Point).
  3. Set the DNS servers to what is listed when you http into the router.
  4. Set the Gateway to 192.168.1.1 (the access point) NOTE: This was changed to 0.0.0.192 on the Ethernet -> Access Point machine
  5. Pray

I'm no network genius, but this is not my first time doing this. Some of this makes zero sense to me (gateway address changed by OS (?) to 0.0.0.192 on a wired connection going straight to the router? subnet mask of 255.255.240.0?).

If anybody cares to comment I will continue to edit this into a decent answer.

share|improve this answer

I tell the router's DHCP server to start assigning numbers at 192.168.1.100, and that way I can use numbers below that for my static ips (servers, mostly).

share|improve this answer

You need to set the DNS server on the computer to the router's address (typically 192.168.1.1). The caching DNS server on the router will redirect the query to the currently configured ISP's routers.

The IP should be chosen from outside the DHCP range (on this particular model, 192.168.1.2 - 192.168.1.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.