Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Windows 7 under VMWare Fusion on Snow Leopard, connecting to my router via Airport.

When I select "Share the Mac's network connection (NAT)" under the Network options, everything works fine.

But I want the Windows VM to have its own, externally visible, IP Address, so I choose "bridged", and now the internet doesn't work in the VM, or takes ages to find sites, and drops connections sporadically.

Anything I should be doing? Is this an Airport-related problem?

share|improve this question

Do you have Internet Sharing turned on? (Even if it's not being used, just enabled). That can cause problems with bridged mode in VMWare Fusion. I was experiencing something similar, turned off Internet Sharing (wasn't actively using it anyways) and the problem went away.

share|improve this answer
    
No Tim - internet sharing is turned off. – Thomas Browne Dec 21 '09 at 11:37
up vote 0 down vote accepted

Actuallly, seems like my router was the problem.

I am based in London, using a very recent 2-wire "business broadband" router from BT. Because it doesn't do Wifi "n" (only b/g) I have a Time Capsule bridged to it which serves as my Wifi node.

Seems either the 2-wire or the time capsule don't like VM Ware bridged mode, since I have another wifi connection (Virgin cable) and that works fine.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .