Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Software Update is broken. I had tried to set it to update from my OS X server (server.local) (instead of pulling from Apple) to save bandwidth, but was never able to get it working. Now when I run Software Update, I get:

The Software Update Server (server.local) is not responding.

Check to make sure your network connection is operating normally. If there are no issues with your connection, contact your network administrator for assistance.

I've tried resetting it back to the default location by doing:

defaults write ~/Library/Preferences/ CatalogURL ""


defaults write /Library/Preferences/ CatalogURL ""

but it still gives the same error.

I've also tried using the Software Update Enabler which had no effect.

I'm was running Leopard when I first encountered this problem. I've since upgraded to Snow Leopard but that had no effect on this issue.

share|improve this question
Did you use MCX (Preference Management in Workgroup Manager) to set your Software Update settings at all? – Chealion Dec 21 '09 at 6:33
Yes. But updating it (for a user) did nothing. I ended up creating a Computer in workgroup manager, entering the IP of my client and setting a proper server which fixed it. – Trevor Hartman Dec 21 '09 at 17:11
up vote 8 down vote accepted

Deleting /Library/Preferences/ should be all you need, but it's possible that the settings lives in ~/Library/Preferences/ as well or even via MCX (Managed Client for Mac OS X). You can check the MCX settings by running sudo mcxquery -user shortusername | grep Update

share|improve this answer
Thanks, the mcxquery command is good to know. – Trevor Hartman Dec 21 '09 at 17:20

markratledge has the command right, but it needs to be run with super user privileges. To do this, copy and paste this exact command into a terminal window:

sudo defaults delete /Library/Preferences/ CatalogURL

It will prompt you for an Administrator password and will complete without any confirmation.

share|improve this answer
This worked for me, (I backed up the file first though just in case). this is the associated docs from the apple site – timhc22 Dec 3 '14 at 12:35

This hint - 10.6 Server: Set the appropriate Software Update Server - says there are now three different update catalogs between 10.4, 10.5 and 10.6; and it also gives a different shell script to delete the existing catalogURL back to default:

defaults delete /Library/Preferences/ CatalogURL

share|improve this answer
Changing the CatalogURL seems to have zero effect on it. Regardless of what I do, I still get the same error message. – Trevor Hartman Dec 21 '09 at 4:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.