Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a samsung T10 (4 GB) mp3 player that is recognized by windows XP as an MTP device, and then I can sync it using both WMP and winamp. However, it does not appear under the file explorer as a mass storage device. I know that this is expected behaviour (it is, after all, not a UMS device). However, I am looking for a workaround that'll allow me to access my MP3 player as a USB mass storage device.

Googling wasn't very helpful. mtpfs seems to do exactly what I want, but it is for the *nixes. Can anybody suggest a windows solution to 'mount' a MTS device under windows explorer. Thanks :!

share|improve this question
up vote 0 down vote accepted

I've patched mine -

Patching a T10.

This is the easiest way to do it, I think

Grab the and unzip it to a simple folder say in drive C:\ , I just use "la" only because at that time I did not know how to spell LaFleur
tcctool link
Or say use msc a folder name if you are using that version.
Use Winzip its far better to use.
Then get hold of patch_it.bat and copy that to the same folder.
patch_it.bat link
Get the T10 Firmware files from here

Unzip the files to the same directory as above and also to the DATA directory of the T10, I had a MTP US firmware, if you are using MSC firmware copy the 2 files to the root/base of the T10, ie, the drive letter of the T10.

This is what it looks like for me using the LaFleur Firmware version

Then hold the power button and press the reset button
release the power button when your PC shows "new device/hardware found"
Do not let windows search for the driver, you must select it manually, you should point to this location as in my case C:\la\tcctool-driver-win32
After that is done just double click on patch_it.bat, I then got a dos window and after download finished , I got a paused message and to hit any key.

I think this is a lot easier than using the Run/Cmd thing.

P.S dont forget to backup your T10 files first, before you do the format thing.

share|improve this answer
thanks for the pointers. will definitely try that tonight, and let you know if it worked. – Manav Dec 22 '09 at 4:57
It worked! Thanks! I used the MSC version of the firmware (I used the Jellymon theme - see the complete list at…). For more detailed instructions, see Also, updating the firmware opened up a lot of bluetooth options, besides making the YP-T10 a mass storage device. I even went ahead and installed the games availiable on the samsung site. yay! – Manav Dec 23 '09 at 5:24
@KnickerKicker anytime dude – admintech Dec 23 '09 at 11:38

I'd posted earlier about mounting a PTP device as a mass storage device, however I can't seem to find any software (yet) for a MTP device. I did, however find a blog entry about a workaround that you can try:

so I looked for a while, and of course, in this operating system was a little “trick” of how, here they are behaving:

  1. Right click on My Computer and go to properties
  2. Go to Hardware tab
  3. Open Device Manager
  4. Search within the portable device, right click to yours and select Update Driver
  5. When Internet Connection pops-up, choose not now and then next
  6. Then click the radio buttom Install from a list or specific location. And finally in the next window, select the option Do not search, select the driver to use and click the Next button
  7. We double click on Mass Storage Device and click on Finish.
  8. With this we finished, we ask to restart, once done, to connect the device automatically appear in My Computer as a normal flash drive
share|improve this answer
I tried your method, but the device manager won't display any other device except the 'MTP Device' option. Thanks anyway :) – Manav Dec 22 '09 at 4:55
Great job! worked for me:) – P'sao Jan 15 '12 at 23:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.