Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to define a String in Eclipse, when I type the " ' button, is not working. When I pressed second time the button, it inserts two ". Solutions?

I want the normal behavior! :)

share|improve this question
add comment

2 Answers

Did you change your keyboard layout to something like US International? This sounds pretty much like dead-key behavior for the " key.

share|improve this answer
add comment

Expanding on Johannes Rössel's answer: here's how to do the swap (assuming you are using a US keyboard and English language version of Windows)

  1. Click the Start button and type "keyboard language". Select "Change keyboards or other input methods".
  2. A "Region and Language" window will appear with the "Keyboards and Languages" tab selected. Click on the "Change keyboards..." button.
  3. The "Text Services and Input Languages" window will appear. On the "General" tab, in the "Installed services" section, look for "English (United States) -> Keyboard -> US". If it is there, skip ahead to step number 7
  4. Click the "Add..." button. The "Add Input Language" window will appear.
  5. Expand the "English (United States)" tree and the "Keyboard" sub-tree under it.
  6. Put a check mark next to the "US" option, then click "OK". Return to the "Text Services and Input Languages" window.
  7. In the "Default input language" section, click the drop-down menu and select, "English (United States) - US".
  8. In the "Installed services" section, click "United States-International" if it is listed, then click the "Remove" button. Repeat this for any other keyboards listed until only the "US" keyboard is listed.
  9. Click the OK button. Return to the "Region and Language" window, then click the OK button.

**Some programs will not notice this change until you reboot your computer.

P.S. to anybody who wants to up-vote this solution: Please consider up-voting Johannes' answer as well. I had this same issue once, and I would not have remembered this if it wasn't for Johannes' answer.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.