Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I open a .doc file in Word 2007 (sorry I am unable to supply the .doc) which pops up with a message above the document "Security warning: Macros have been disabled" but there are no macros shown in the macros listing and no functionality displayed in the VBScript editor.

Why does Word think this document contains macros and how can I remove them to prevent the warning?

Thanks,

Tom

share|improve this question

3 Answers 3

I think Word is simply reporting that the properties of the document are configured to disable macros.

This is not the same as saying there are any macros.

If there were macros, they would be disabled.

And it's only a warning message. If you can configure the document not to disable macros, the warning should disappear.

share|improve this answer

If the file used to have macros and they were removed, it can still get incorrectly flagged by the security features as it can see the module exists even with no code in it.

Steps to reproduce problem: Open Word document. Open VB IDE (ALT-F11) Find the document project in the navigation pane. Right click > insert module. This creates a branch for "Modules" containing "Module1". Don't add anything to Module1. (This is basically the same as if someone recorded a macro then went and deleted it but did not actually remove the module).

So, for your troublesome document, open it, then ENABLE the content (if you don't you won't see it in the IDE). Alt-F11, go find the (empty) module and right click > remove. Don't bother to export before doing this (since it's empty, right?) Save and close the document.

If you are unsure about the provenance of the document and don't feel happy enabling the content, this should work (your mileage may vary): Open doc. Don't enable content Alt-F11 Find the document and right click > insert a module. Now remove that module and the IDE deletes the modules container with it, along with the disabled modules. Save and close

share|improve this answer

Install share components can solve this problem.

share|improve this answer
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  AthomSfere Jun 27 '13 at 13:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.