Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm working on Windows XP Pro.

I have 2 internet connections - one cable, one ADSL - and I'm trying to hook up using a load balancing router (D-Link DI-LB604). Everything is working just great - except I can't connect to my work VPN. If I plug my computer directly into either the cable or ADSL modem, I connect just fine using the native Windows VPN connection; as soon as I hook up through the load balancer, I cannot connect to the VPN (error 800).

There must be some secret switch on the load balancer that allows me to dial in to the VPN - but what?

I tried lookup up support on D-Link's web site, but their support section is very scant on details, the product has been discontinued, so they don't support it over the phone, and the forums are a complete maze of useless topics, none of which appears to be about getting tech support.

Any ideas or pointers how to get this working?

Thanks!

share|improve this question
add comment

2 Answers 2

See this thread: VPN Pass-through not working on D-Link DI-524.

I quote:

I don't have the same router, but on my router dir-655, you will need to set this in the virtual server list...

Gre:
Under traffic type, the protocol is "Other", and set to 4. The public and private field should greyed out. Ip, is ip to your server.

pptp:
Under traffic type, the protocol is "TCP", and set to 6. The public and private field is set to 1723. Ip, is ip to your server.

Make sure your software firewall allows this. (you can disable it)
Make sure in the ALG section that pptp is checked. (all the options there should be already checked by default)

Does this help?

share|improve this answer
    
+1 not exactly what I'm looking for, but as a result of looking for the settings you described I did find some kind of secret switch which I'll describe in my own answer. –  Shaul Dec 21 '09 at 14:19
    
That's why I quoted the above - in order to start you on the way to the right setting. Remark: The right etiquette is to add your own info in your post, and credit the person who put you on the right path. –  harrymc Dec 21 '09 at 14:30
add comment
up vote 0 down vote accepted

On the "Tools->Misc" page of the router configuration I found a setting "PPTP Passthrough", and "Enabled" was set to false. I checked the "Enabled block, and Bob's your uncle!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.