Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I used to access the VPN connection in my host machine from my Windows XP guest. Since upgrading to 10.6 (10.6.2), I can no longer access the host's vpn.

I have tried setting up the VPN in the guest itself. Though it finds the VPN IP address, it says that host does not respond.

I need to access this VPN from the guest. Any ideas?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Most likely this is a problem with using the virtual network adapter in NAT mode, switch it to bridged mode in the VM in question and your VPN connection should work.

share|improve this answer
    
I'll check that out, thanks. –  Yar Dec 21 '09 at 16:45
    
Hmmm... now the VPN connection works, but it can't actually do any DNS resolution as it's supposed to. +1 for now. –  Yar Dec 21 '09 at 17:34
    
Sorry, the question is: how can I get the DNS specified by the VPN to take precedence over the DNS from the bridged connection? Unfortunately, my ISP resolves all requests, even those it cannot resolve (to its own error page) –  Yar Dec 21 '09 at 17:38
    
That is really a different question/problem that is specific to Windows XP. There are several ways to address it but it depends on your VPN technology and Windows XP configuration. –  Goyuix Dec 22 '09 at 16:10

This is very product specific. I recommend you try the VirtualBox forum over at: http://forums.virtualbox.org/index.php

share|improve this answer
    
I will try there, but I'm 90% sure the problem is just a Snow Leopard problem. –  Yar Dec 21 '09 at 16:13
    

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.