Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a laptop running Windows XP (too old to upgrade) and it does something that's maddeningly frustrating: every now and then, I find my network connectivity has disappeared. If I go to my "Wireless Networks" window, I see that my access point is listed, except where it should say "Connected" it just says "Automatic."

This is where I curse my computer and ask, "If it's Automatic, then why aren't you automatically trying to reconnect!?"

So then I double-click the access point's listing, and I get the "Type in the password for this access point" box, except the password field is blank. It shouldn't be, because Windows knows the password.

So I click Cancel without typing anything in.

Then it automatically refreshes the list of available access points. This time, it automatically connects and doesn't need to ask me for the password because it already knows it.

I have to do this like five times a day. Is there a workaround? If not, is there some open source or non-crappy freeware that replaces Windows XP's crappy WiFi subsystem with one that actually remembers passwords all the time and actually tries to reconnect to my home LAN all the time?

P.S. This isn't, "Oh, maybe you walked out of range or the access point had a hiccup and so Windows tried once to reconnect and it timed out." I'm usually using the computer when it happens and flip over to the Networks window (which I now keep open all the time) within about a second, and it's already in "Automatic" mode. And this happens even if I'm in the same room as the AP.

share|improve this question
1  
Have you tried upgrading your network drivers so that you don't have to reconnect in the first place? –  Stefan Thyberg Jul 19 '09 at 16:04

2 Answers 2

up vote 1 down vote accepted

There might be a third-party wireless suite you can use, depending on your wireless chipset. For example, Intel has a very good wireless suite for its WiFi chipsets, found here:
Intel PROSet/Wireless

share|improve this answer

When I have this problem, I reboot my WiFi router, and the problem goes away for a few weeks.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.