Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Suddenly, whenever I try to install something new on my system, all goes well until it gets to the point of creating Start Menu icons. At this point, I get an alert saying that the installer doesn't have permission to access the Start Menu folder, and my only options are Ignore, which just keeps triggering the same alert, and Cancel, which totally undoes the installation.

I've tried disabling UAC (which is a feature I detest anyway), and running the installer as administrator from a R-click. Neither works. I also have 8 subfolders under my c:\users folder with various names, som of which I can look into and some which I cant. I have no idea where all this stuff came from, since I have a personal PC for home use and nobody uses it but me.

Any suggestions, anyone?

Thanx,

T.E.Ponta

share|improve this question
    
Part of the problem is you detest UAC but you have no idea what the user and permission model for Vista is supposed to be. Hopefully once this is on SuperUser someone can help you get sorted out. –  jball Dec 21 '09 at 20:46
add comment

migrated from stackoverflow.com Dec 21 '09 at 20:52

This question came from our site for professional and enthusiast programmers.

1 Answer

Check the Permissions on "C:\ProgramData\Microsoft\Windows\Start Menu\Programs".

The accounts/groups System and Administrators should have full control and no Deny flags. The owner of this directory should be Administrators.

If this is not your situation, please post some more info.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.