Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to use Skype with Ubuntu Karmic and I just don't understand how to configure Pulseaudio properly. The previous version of Skype allowed me to talk through and hear the voice on my USB phone and the ringing sounds through my laptop speaker. I'm not able to do this with the new version (2.1.0.47).

share|improve this question

5 Answers 5

You may want to try reinstalling PulseAudio via the instructions at http://ubuntuforums.org/showthread.php?t=789578:

1) Backup (and then delete) your previous configuration files:

mkdir ~/pulse-backup && cp -r ~/.pulse ~/.asound* /etc/asound.conf /etc/pulse -t ~/pulse-backup/
rm -r ~/.pulse ~/.asound* 
sudo rm /etc/asound.conf

2) Ensure you have the necessary PulseAudio libraries and configuration utilities installed:

sudo apt-get install libasound2-plugins padevchooser libsdl1.2debian-pulseaudio

3) Ensure the evil "libflashsupport" library is not installed:

sudo apt-get remove --purge libflashsupport flashplugin-nonfree-extrasound

4) (Karmic users - please skip this step, it's not necessary).

5) Open the PulseAudio Volume Control application ("pavucontrol", or you can launch "Applications/Sound & Video/PulseAudio Device Chooser" and select Volume Control from this applet's menu). In the Output Devices section you will see a listing of the playback devices available on your system. Right-click on the entry that you desire to be made the default playback device on your system and enable the "Default" checkmark. Similarly, navigate to Input Devices, then right-click on the device you wish to set as your default input device (microphone), and ensure the "Default" setting is checked. Close the application when you're finished.

pulseaudio & pavucontrol

6) Ensure that your sound card's PCM mixer is not muted or set to 0% volume (this appears to be a common bug in Intrepid and Jaunty):

alsamixer -Dhw

The Key step is step 5 where you define what devices are used for input and output. Doing this allowed Skype to work with my hardware.

share|improve this answer
    
Thanks for going into this in detail but the issue is not that my Pulseaudio is not working properly. It works, but I have no idea how to configure it to work in the way I need. Currently, when Skype uses Pulseaudio, all output is handled by laptop speakers and all input is handled by laptop internal mic. If I plug my USB phone in, then all output and input is handled by the phone. But I am not able to configure it so that all ringing is handled by laptop speaker but all conversations are handled by USB phone. The problem is that I am not understanding Pulseaudio. –  nitbuntu Dec 30 '09 at 11:33
    
I can't seem to find any user-friendly instructions for controlling Pulseaudio. The previous version of Skype was easier to configure sound settings. –  nitbuntu Dec 30 '09 at 11:34

Pulse and Ubuntu 9.04 do not work well together. I can't use my microphone with Skype or Ubuntu's own sound recorder. Yes, all volumes/mixer settings are correct. It does not appear to be a settings or configuration issue for me. Besides, what's more basic than a microphone? Sadly, I can't upgrade my Ubuntu version because 9.04 is the last version that is stable with my NVIDIA card. So now what I'm looking for is a way to upgrade the pulse version without screwing with anything else. Wish me luck.

share|improve this answer

In my sound preferences, I have 'PulseAudio server(local)' for Mic, Speakers, Ringing. And it works. I don't think I had to configure anything manually. Try reinstalling skype maybe.

share|improve this answer
    
Unfortunately reinstalling skype doesn't seem to make much difference for me. I just can't seem to make any sense of Pulseaudio volume control or device chooser. –  nitbuntu Dec 23 '09 at 13:44

On my system the notification sounds (login, incoming call ringing, etc.) didn't work but audio during calls worked fine.

I found out that I didn't have pavucontrol installed. I installed the pavucontrol package and launched pavucontrol. On the Playback tab I found out the System Sounds volume was set to 0%. I adjusted the volume up and now it is working fine.

share|improve this answer

This is meant to be easy - basically PulseAudio has the concept of sound streams that come from applications. You can retarget the sound stream to a different hardware device.

Unfortunately not having multiple hardware devices here I can't test whether the new GNOME volume dialog lets you easily do this, but the KDE Phonon dialog is supposed to according to http://fedoraproject.org/wiki/Features/KDE_PulseAudio_Integration - not sure if/when this has hit ubuntu

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.