Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since yesterday my main Windows 7 computer (an HP portable) won't boot. The apparent cause was a disk error, which seems to be fixed (but not sure, as chkdsk went fine. At first it couldn't find the boot loader (which I fixed with bootrec), and later complained of I/O errors in winload, later in other drivers.

  • System restore fails with a broken system.sav
  • System repair says the system is OK (but it did repair a few issues). Still its log shows problems
  • I replaced drivers from the original CD (which might have been a bad idea), but fixed some more
  • sfc /scannow says everything is OK (even specific file)

Do I have any options left apart from doing a full reinstall? (which apparently won't preserve my settings, as I cannot do an update from Windows -- it won't boot)

I've spent 8+ hours trying a few things!

share|improve this question
    
"System restore failed to extract a file (...) from restore point. Where are those on the file system? –  Marco Cantù Dec 22 '09 at 16:26
    
Update: After a few more hours, a low level disk check telling me the disk was fine I noticed the BIOS date was very old and remember updating the BIOS to be able to install 7. I also had to disable the SATA support (which I already did before updating the BIOS, to no avail). And lol, everything seems to be working! Will backup and take precautions, of course... –  Marco Cantù Dec 23 '09 at 9:22

7 Answers 7

up vote 3 down vote accepted

I would start by making a mirror copy or a full backup of the drive and then take a look at the SMART status of the "failed" drive. Your best bet for a SMART utility should be to start at the Drive's manufacturer website and check what they offer as far as diagnose utilities. Such utility may reveal that the drive is indeed failing or that the failure is at a logical level. Based on that finding I would pursue either fixing the original drive (logical failure) or the mirrored drive (imminent drive failure). Good Luck!

share|improve this answer

I agree with fluxtendu, it sounds like your hard drive is about to fail. You might try SpinRite,

If it does boot, the first thing you should do is back your data and run the "Windows Easy Transfer" to backup all your settings.

share|improve this answer
1  
I was wondering if there is a way to run "Windows Easy Transfer" on a computer that doesn't boot. I doubt. As it seems only a handful of configuration files have issues, it would be nice to transfer the registry and installation setting and reinstall the OS. –  Marco Cantù Dec 22 '09 at 20:55
    
Why are you promoting the long abandoned unsupported proprietary commercial tool which always crashes on current HDDs? –  Ark-kun Mar 31 '13 at 21:41

It looks like an imminent dead of your hard drive.

The first thing you should do it's a backup of your important data (with a bootcd or by plugging your hd in another computer) After that you should do a true deep scan of your hd with the bootcd of your hard disk manufacturer.

And at this time, if you don't find no more error on the hard disk, you may think at saving your settings

share|improve this answer
    
I did a network backup (could and still boot a "repair" WinXP) of all relevant stuff, as least. Backing up system files at this point looks irrelevant, if they are messed up. I'm not really convinced the disk is at fault, will do a low level test with the BIOS / HD tool. –  Marco Cantù Dec 22 '09 at 20:48

For a friends PC I was troubleshooting after it did a windows update in windows 7 his PC wouldn't restart, boot off of a windows 7 recovery disk, notta. Based on the post above I had a hunch that his USB hub could be the culprit since someone had mentioned supporting legacy USB devices. That being said as soon as I unplugged the USB 2.0 hub device is working like a champ. Not sure which windows update do this but it was a week ago from the 7th of december.

Hope this helps other people who are out there in a distressed state fix their issue.

share|improve this answer

I have a Dell desktop with Windows 7 home premium 64 bit circa Feb 2010. It could not boot up in repair mode and in safe mode got stuck loading either classpnp.sys or disk.sys, depending on whether it was trying to load from the hard disk, the recovery disk or the reinstall disk. So I couldn't get to a command prompt. My mouse and keyboard were both wired and running off a USB hub. Dell support, after two hours of failed attempts to deal with this, and refusing to comment on the classpnp.sys issue that is the topic of so many threads, had to call it a night and said that my $130 one time fee would cover me to continue working on this the next day. So I read the thread about USB and so switched them to plug directly into the computer rather than via the USB hub. That fixed the problem entirely. No need to wipe out my hard drive which was the path Dell support was heading down if they had been able to get the reinstall disk to work, which fortunately they did not.

share|improve this answer
  • Reinstall to another partition
  • Backup the data
  • Blank the hard drive
  • Run disk diags with ubcd
  • Move any bad sectors to the end of the drive partition
  • On your new installation leave 1GB unpartitioned
  • Think about purchasing a new hard drive
share|improve this answer

I had only a few minutes a similar issue with Windows 7 RTM 64bit. Funnyly, I was then not able to boot any of my Windows OS on my system (at least the OS's I tried ;) Windows XP SP3 and the Windows 7 RC2 64bit). The best is to check the BIOS (usually F2 on bootup) and switch some options off (in my case it was the USB legacy support). I also re-adjusted the USB devices, so, that Windows had ro look for them again. I guess, this distracts Windows so much, that it will boot properly and only then search for the correct drivers (Found new hardware and install drivers). I had similar issues before. It must be something during the check for PNP hardware, where the Windows versions get stuck. This happens more and more with more advanced versions (i never had this with Win2k and lower and very rarely with XP, but Vista and Vista 64bit were worse). But currently this is quite regulary in Windows 7 64bit, even if I love its speed. Best regards T

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.