Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have some problems connecting to my office from home. I'm getting the following error message:

Remote Desktop Connection cannot verify the identity of the computer that you want to connect to.

Try reconnecting to the Windows-based computer, or contact our administrator.

I have downloaded CoRD, and for some reason, that works okay. I can also connect from a Windows 7 running on VMWare Fusion. On Windows 7, I use SonicWall Global VPN Client, and on the Mac, I use VPN tracker, if that is related...

What's going on?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Found the answer myself:

In Remote Desktop Preferences, go to Security-tab, and select the option 'Always connect, even if authentication fails'.

Some more info:
The error I got, means that the remote desktop client could not verify that the remote machine is the machine that I wanted to connect to.

In Remote Desktop Connection, server authentication verifies that you are connecting to the correct remote computer or server. This security measure helps prevent you from connecting to a different computer or server than you intend to connect to. This also prevents you from unintentionally exposing confidential information.
http://support.microsoft.com/kb/925876

So by telling the remote desktop client to connect, even though the verification failed, the problem was solved.

Apparently, there are some settings related to this issue that can be tweaked on the remote machine, but I have not tried any of them. http://technet.microsoft.com/en-us/library/cc753945(WS.10).aspx

Nor have I done any research to find out why the client can't verify the remote server.

share|improve this answer
    
Can you elaborate on your solution for those of us who might be suffering from the same problem? Thanks! –  user62485 Jan 11 '11 at 22:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.