Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Since a few days ago the sleep modus on my Macbook isn't working anymore, and I don't know why. After 10 minutes the Macbook isn't falling to sleep as expected. Does anyone have the same problem or have an idea how to solve this problem?

The OS on the Macbook is Snow Leopard 10.6.2.

share|improve this question
Does the MacBook sleep properly when you close the lid? Check to make sure that there no applications running that would disable the automatic sleep function (e.g. Transmission). – fideli Dec 23 '09 at 0:04
When I close the lid everything is fine. When I schedule Eyetv the notebook wakes up correctly, too. But it's not falling back to sleep. Is there a list with "sleep critical" applications available? – 1passenger Dec 23 '09 at 0:12
Not really. One test you can do is set the sleep timer, then shut down every application, including processes in the menu bar. Then see if it sleeps. Update your above question with details from this test. Then we can isolate whether or not the problem is system-related. – fideli Dec 23 '09 at 2:52
What about some hot milk? :))) – Shiki Jun 8 '10 at 7:02

I've run into the same problem with my old Powerbook G4 on Leopard. Make sure that any graphic intensive applications are hidden [or closed.] And make sure that any external devices do not disturb the computer. Hope this helps :)

share|improve this answer
like cats. cats will wake up the computer if you're not careful (or, y'know, they're bored). – quack quixote Jan 28 '10 at 18:15



OK so my sleep problem is resolved, I cannot pinpoint the fix but since upgrading to 10.6.4, Mail 4.3, Safari 5 and iTunes 9.2 the problem is no longer. Unfortunately I only found this to be fixed by accident as I have been closing the lid on the laptop instead of relying on power saver settings, today I got called away from the laptop in a hurry and left the screen open only to find that on my return the Macbook Pro was indeed asleep. Just though I would update the thread and let you know that one of the above is most likely the culprit as these are the only only changes that have been made to my system since my comment below in May. I have tested that sleep works with the lid open a number of times this afternoon and it has worked every time.

Original comment (may be useful for some)....

Yes I am experiencing exactly the same issue on exactly the same OS version. Although old, I have tried the fixes mentioned here but this did not work for me, you may want to try it yourself...

I have tried a reboot without loading anything except the startup items which are DropBox, Mail, ISyncIt, VMware Fusion Helper, iTunes helper and GrowlHelperApp and I am still encountering this problem. I am going to try a reboot and disable everything in the startup to see if one of these apps or helpers is the culprit and I will post back the results, I seem to think this is a Snow Leopard issue though and have found various other sites where people are mentioning exactly the same problem.

EDIT Sorry for posting this in the answer section, i'm new here and this was accidental :/ Just wanted to add comment.

share|improve this answer
Still have this problem with 10.6.3. It's driving me wild. Anybody know a fix? – Someone May 11 '10 at 20:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .