Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My host is WinXP and my guest (on VPC 2007) is also WinXP. Both have SP2. I am unable to ping either from one another. However, I am able to connect to the Internet from the guest. My intention is to be able to connect the SQL Server on the host from the Management Studio installed on the guest. Right now I am using Shared Networking (NAT) on the guest's settings.

share|improve this question
add comment

1 Answer

You want to use Bridged networking. This way, both the host and the guest will talk to your router/LAN to get an IP address on the same subnet.

With NAT, the host is acting like a router, and all you VMs are "behind" it on their own private network.

EDIT: Sorry, I was using VirtualBox terminology. As harrymc said, choose the card you have, not the other generic choices. I was able to ping out from an XP guest to the XP host, and from a Win2K guest to the XP host; from the XP host to the Win2K guest, but not the XP host to the XP guest. Then I turned off the firewall on the XP guest, and then that worked too. So there's also a firewall configuration issue, which might be handled automatically when you install a server program on the guest. But since you intend to go from the guest out to the host on the server, it may not matter.

As a first troubleshooting step, you can do an ipconfig and see if the addresses look right. For example, behind a typical home router, everything might be 192.168.0.something, with each "something" being unique.

share|improve this answer
    
Well, I not being a Networking guy won't know much on the subject. The options I have for Network Adapters are "Local Only", "Microsoft Loopback Adapter", "Broadcom 440x 10/100 Integrated Controller" and "Shared Networking (NAT)". Now how do I go about using Bridge Networking? –  user22441 Dec 23 '09 at 12:21
    
Using Broadcom as 1st adapter means the VM will get its own IP address and will appear in the network as any other computer. –  harrymc Dec 23 '09 at 14:06
    
Sorry, but couldn't get this working either. Is there any way to troubleshoot this? –  user22441 Dec 23 '09 at 18:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.