Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem when trying to work with USB devices mounted with user 'root'. I explain, I mount a USB device as root under command line (console mode only), and I can work with that device with no problem, but when changing to one limited account, that device mounted is in read-only mode. I've tried to apply chmod and chown but not to work. Also, I've tried this:

$ sudo mount -t vfat -o rw,users /dev/sdb1 /mnt/pen/

and same result. How can I resolve this without using fstab file? I think there must be a solution, 'cause under X-Windows with a limited account, this USB device is recognized, mounted and worked with no problem.

share|improve this question

migrated from stackoverflow.com Dec 23 '09 at 20:31

This question came from our site for professional and enthusiast programmers.

add comment

2 Answers 2

Try using the uid and gid bits to specify you as the userID which owns the file. You may also want to use umask:

sudo mount -t vfat /dev/sdb1 /mnt/pen -o umask=022,rw,uid=1000,gid=1000
share|improve this answer
add comment

Under GNOME, there's an automounter (part of Gnome-VFS) that provides automounting when HAL/Dbus notifies it that a new device has become available (USB stick plugged in, CD inserted, etc).

To run a 1-off on the commandline, use the mount options uid and/or gid (and/or umask) as John T's answer shows.

To run a system-wide automounter, use HALevt. See my answer to this question for getting HALevt to work on a headless system. In your case, you might tweak things to run the HALevt daemon as your user.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.