Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install a VB6 Windows program that uses OLEDB to access VFP tables to run under Wine 1.0.1 on Ubuntu 9.10. Wine is configured to Windows version Windows XP. The program install ran okay, and I used winetricks to install MDAC 2.8 and JET 4.0 sp7. I also installed Microsoft's vfpoledb and vfpodbc drivers. The application starts and displays an error message, item cannot be found in the collection corresponding to the requested name or ordinal. Does anyone have an idea how to fix this?

share|improve this question
    
Are there any other details about the error at all, I don't have enough experience of Wine to know whether it has an "Event Log" which may contain errors, or the application itself may maintain it's own error log in the program directory (bit of a long shot). –  Richard Mar 16 '10 at 11:41
    
@Richard, this is my first use of Wine so I don't know how to do any in depth debugging either. This is all I have except that I can use a Visual Fox Pro tool from the same company to verify the tables are correct. –  Beaner Mar 16 '10 at 14:34
    
Are you sure that jet 4.0 is the right library? –  horatio Sep 6 '11 at 15:19
    
@horatio - Yes, The program is for Windows and I have a lot of experience setting it up. I tried to do this because we sometimes get calls from a potential customer that wants to do something like this. Since Ubuntu (and Wine) have updated this error has gone away, I have new ones, but the whole thing is impossibly slow so I quit even trying to get this working completely. –  Beaner Sep 6 '11 at 17:23
    
ahh, somehow I missed the ask date on this. I wonder why it was up on the top of the list... –  horatio Sep 6 '11 at 19:40

2 Answers 2

try winetricks mdac28 http://wiki.winehq.org/winetricks

share|improve this answer
    
I have used winetricks to add both MDAC 2.8 and JET 4.0: see the question. I did that to solve an error 429. –  Beaner Dec 23 '09 at 21:56
    
Sorry, I totally missed that. I can tell you that the error usually pops up when there is a misspelled field name in the source code. Ie: rs.fields("UesrName") instead of rs.fields("UserName"). Can you verify that it does run on windows without the error? –  bugtussle Dec 23 '09 at 22:07
    
I guess I should have included that. This is a commercial point-of-sale program running on hundreds of Windows computers from Win2k up. –  Beaner Dec 24 '09 at 1:09
    
Contact the developer. They may have a diagnostic tool or give you a better idea of what the problem is. –  bugtussle Dec 24 '09 at 1:26
    
Not an option - the program is meant to run on Windows so what I am trying is unsupported. –  Beaner Dec 29 '09 at 5:14

Ugh, I always had trouble with MDAC / JET on Windows, let alone trying to do anything like this, there is no guarantee that this will work but you might try the Component Checker Tool here to see what version it thinks is installed?

http://support.microsoft.com/kb/301202

share|improve this answer
    
That was a good idea, wish I'd thought of it. Component Checker v2.0 just goes away after a few seconds except on Scan your machine. Do not perform analysis. I tried re-running Winetricks MDAC2.8 install, but it did not make a difference. –  Beaner Mar 15 '10 at 19:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.