Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Virtual Box on Machine and setup a Ubuntu 9.10 machine. And I have an external hard drive formatted for linux. But when I hook up the external hard drive, my ubuntu 9.10 can't see the external hard drive. Can you please tell me how to setup the external hard drive for my ubuntu 9.10 environment?

Thank you.

share|improve this question
add comment

2 Answers

In the settings for your virtual machine, ensure USB is enabled and add a USB device filter so it can only be picked up by the virtual machine when it's running:

alt text

share|improve this answer
    
Thanks. But what kind of filter I should add to allow me to read/write to this external hard drive? I tried 'Generic', but it does not work. I tried 'New Filter', it does not work either. –  hap497 Dec 24 '09 at 7:14
    
There should be preset filters if you have the device plugged in. It will show up as an option when you click on the usb cable with the + on it. –  John T Dec 24 '09 at 7:39
    
I get "no device available" –  gcb Dec 14 '13 at 8:52
add comment

If USB does not work for you like it doesn't for me, or if your drive is not USB, but eSata... you may need to access the device raw.

it is possible, but not available on the usual interface.

http://www.virtualbox.org/manual/ch09.html#rawdisk

READ THE ABOVE INFO! you may lose data if not!

here is the reference for people who already read the above and just want the reference (i know it will probably be me a few months...)

VBoxManage internalcommands createrawvmdk -filename sdd.vmdk -rawdisk /dev/sdd

then go to the interface, with the machine OFF (not suspended) and add a new disk, chose the vmdk you just created, boot it and done.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.