Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I’m playing music on my MacBook Pro (model 5,1, OS X 10.5) using VLC (1.0.3). When I shake my laptop, the playback stumbles, much like when shaking an old portable CD player (and by “shake”, what I really mean is “carefully carry it from one location to another”. I am most assuredly not shaking it around like mad).

Note that I’m playing music files form my hard drive, not from a CD. Other music players don’t exhibit this behaviour.

I surmise that this is an Easter egg built into VLC that uses the HD’s motion sensor to recognize shaking motions and emulate this “feature” of portable CD players.

Still, it’s kind of annoying because it kicks in whenever I carry the laptop around. How can I disable it?

share|improve this question
1  
"How can I disable it?" go solid state. –  Molly7244 Dec 24 '09 at 16:12
    
@Molly: yes, that would indeed solve the problem but it’s slightly beyond my budget. ;-) Anyway, I actually thought that VLC had buffering enabled and was intentionally introducing these hiccups as an Easter egg. –  Konrad Rudolph Dec 25 '09 at 16:55
    
hence i made it a comment rather than an answer. even if you can disable the HDD protection mechanism, i wouldn't recommend to do it, as it has its purpose (e.g. protecting your budget :) –  Molly7244 Dec 25 '09 at 16:59

5 Answers 5

up vote 3 down vote accepted

As others have already guessed, it's probably the Macbook's sudden motion sensor combined with the fact that VLC has a very small playback buffer out of the box. Increasing the buffer size should fix the problem.

My Macbook is at home at the moment, so I'm working with the Linux port of VLC here, but the basic process should be the same. Under Preferences, make sure you have it set to show you all settings rather than "Simple."

Next browse to Input / Codecs --> Access Modules --> File. The default caching value on my install is 300ms. I'd imagine that bumping that up to a few seconds should solve your skipping problem.

share|improve this answer

Back when pocket mp3 players used tiny spinning drives, they had the same issue. The harddrive is sensitive to vibration and as it tries to re-align it's heads after a vibration event, there is a delay that can be long enough to leave a gap in the music playback.

I'm not familiar with VLC, but there might be an option to tell it to load the whole track into memory in one go which should reduce this problem.

share|improve this answer

ThinkPad laptops with motion sensor has the "feature" that parks drive heads when you shake the computer. It is here to save your HDD in case laptop will fell down or hit something very hard. But it does affect music and video playing the same way - it stops for a seconds. Not sure if Macs has that "feature" though.

share|improve this answer
2  
Then why only with VLC and not with other music players? –  Snark Dec 24 '09 at 13:25
1  
VLC might be streaming directly from disk instead of buffering the track in RAM. Hard to say without seeing the source code, but that's the most likely explanation. –  Brian Knoblauch Dec 24 '09 at 13:47
2  
Mac laptops do have this feature. –  ceejayoz Dec 24 '09 at 16:09

Mac Laptops have what's called a "Sudden Motion Sensor" and will stop the hard drive if it detects motion. The idea is to prevent damage to the drive while it is spinning so you won't lose your data or the entire drive. This is a good thing. Macbook Pro's aren't meant to be portable media players.

share|improve this answer
    
I am aware of the motion sensor (see question), I know that it is a good thing, and I am not using my laptop as a portable media player. Apparently I need to word my questions more carefully. Still, thanks. –  Konrad Rudolph Dec 25 '09 at 16:52

How can I disable it?

Stop shaking it? This is intended to save your hard drive from serious damage. If you want to listen to music on-the-go, that's what an iPod is for.

share|improve this answer
    
For the record, I don’t “shake” the laptop. I am occasionally (and carefully!) carrying it from one desk to another. Other players are fully capable of coping with this. So why isn’t VLC? Honestly, “stop shaking it” isn’t a very useful response. –  Konrad Rudolph Dec 25 '09 at 16:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.