Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have netgear DG834G which I use as ADSL Modem + Wired/Wireless Router. My Wired LAN is on 192.168.0.0 network, netmask 255.255.255.0, everything works OK.

when I tried to connect my iphone using DHCP, the ip address given is 169.254.217.178, subnet mask 255.255.0.0 I cannot access the internet from my iphone, presumably because of different subnet mask? (previously i can access internet ok using wifi, but didnt take note of the ip address)

I tried using a static ip address on my iphone, but no luck.

So is this 2 different subnet coming from 2 different interfaces (wired and wireless)?

What can i do to fix this?

share|improve this question

2 Answers 2

The second "subnet" is an automatically generated bogus address. This happens on any device where it can't contact the dhcp server.

Does that static ip not work even when you manually specify everything? Including the gateway and dns servers?

If this is the case then there is probably something wrong with the router or its configuration. (possibly the encryption scheme or something, hard to say)

One thing you could try is just to reset the router to defaults and see if the iphone can connect then. If it still doesn't then there might be something wrong with the router.

Do other wireless devices work?

share|improve this answer
    
yes everything is ok once I restarted the router. :) –  portoalet Jan 1 '10 at 14:48
up vote 1 down vote accepted

One very simple and classic solution to this, restart the netgear router!

I didn't reboot the router everytime I changed something on the wireless settings.

Once it's restarted, it can detect my iPhone on wireless and assign the ip address on the proper network (192.168.0.*)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.