Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I own a new HP Compaq 615 laptop which has a network adapter (RJ-45 standard connector) built-in.

Today it is not recognizing the network cable at all. Tried the cable in the desktop PC and it works perfect. Restarted the OS (Windows 7 RC) and tried "Diagnose" on the network adapter and "Troubleshoot". Nothing...

It sucks that on Christmas Eve this thing is acting up and I need some tips on how/what to check on it before I get the chance to go to the dealer with it (it's still in warranty).

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Drain the 'Flea Power':

  • Remove the battery and then disconnect the AC adapter if connected.

  • Press and hold down the power button for 15 seconds then release it.

  • Reinsert the battery and then reconnect the AC adapter.

  • Turn on the computer.

share|improve this answer
    
OMG it worked!!! THANK YOU SO MUCH! I don't get it why it worked but then again I have my problem fixed :) –  Andrei Rinea Dec 24 '09 at 21:16
    
i have an old desktop PC with on-board LAN doing exactly the same every now and then, a minor annoyance when you know how to deal with it. however, this problem is not likely to go away and since the laptop is still under warranty, you might as well claim a replacement. –  Molly7244 Dec 24 '09 at 21:27
    
Being an engineer graduate and having a researcher's curiosity I was asking why this condition appears. I understand you don't happen to know the exact internal details? –  Andrei Rinea Dec 24 '09 at 23:15
    
no, i don't know how and why the network controller got messed up, but completely discharging all capacitors is a cure that often works in this and and other cases (it sometimes helps if the computer wont turn on at all, this 'phenomenon' is also reported to disable the keyboard of Dell Studio Laptops) . you see, this little trick will drain all remaining power from the circuitry and rectify a veriety of issues. –  Molly7244 Dec 25 '09 at 0:39
add comment

First I'd try blowing in the RJ-45 slot on the laptop (if you have compressed air, all the better). Sometimes a bit of dirt or dust may cover one of the connectors. Try rubbing a dry qtip on the connectors of the laptop and the cable.

If that yields nothing, it's probably a physical problem with the NIC. My best recommendation, so you don't void your warranty, is to not open the laptop and tinker with it.

Have a Merry Christmas!

share|improve this answer
    
I don't know for sure if draining the "flea power" as per Molly's answer was the only thing that fixed it. I blew air (by mouth ;)) ) in the connector and this might also helped. So, as I can't choose two answers I went and upvoted a question of yours in return. :) –  Andrei Rinea Dec 24 '09 at 21:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.