Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I get VLC to play on the second monitor on Windows? On Mac OS, there is an option in the video menu "fullscreen video device". Windows doesn't seem to have that option.

There are various options in the DirectX settings that let you select a monitor, but they don't seem to work simply.

share|improve this question
    
do you mean fullscreen spanned over BOTH monitors? –  Molly7244 Dec 24 '09 at 21:31
    
No, just on the second monitor. Like a powerpoint presenter view type of thing. –  rjmunro Dec 24 '09 at 21:36
    
I don't like to give advice such as "bad programm, change programm", but in this case, you might find that Media Player Classic has a lot more options, like "always start in full screen", "don't exit at the end of the movie", a good support of mutli-monitor, etc. It's perfect for quality presentation... –  Damien Dec 26 '09 at 12:54

4 Answers 4

up vote 6 down vote accepted

It has the option, it's just kind of tucked away a bit. Under Tools -> Preferences go to the Video section and choose your display device in the DirectX settings:

alt text

You can use \\DISPLAY2 in a multi-monitor configuration. Ensure you are using DirectX instead of Default as the output (in the Display section above).

share|improve this answer
    
Tried this, and it didn't work. I got no video appearing anywhere. But well done for posting screen shots and everything :-) –  rjmunro Dec 24 '09 at 22:06
    
Did you explicitly set the output to DirectX? –  John T Dec 24 '09 at 22:09
    
doesn't work for me either. and yes, output is set to DirectX. –  Molly7244 Dec 24 '09 at 22:17
1  
On another attempt, I did get it to work, but I had to quit and reload VLC after saving the settings. It works, but changing the settings to use it is a bit unreliable. I still can't preview / cue on the main monitor and then play full screen on the second monitor, like on the Mac version, though. –  rjmunro Dec 28 '09 at 12:34

Drag the VLC window to your second screen.

Then go to Tools > Preferences > Video > Display and check Fullscreen.

Close VLC, done.

VLC will now remember its position and always start videos in fullscreen mode on the second monitor (until you change the position to the primary display or the secondary display becomes unavailable, that is.)

share|improve this answer
    
He wants it to always go there in fullscreen though, like the option on Mac to choose a fullscreen video device. –  John T Dec 24 '09 at 21:50
    
This is for a presentation situation in front of lots of people, so dragging windows on and double clicking is kind of amateur. The thing is that it's really really easy on the Mac version - the "Fullscreen video device" menu just does exactly what I want. –  rjmunro Dec 24 '09 at 22:00
    
i will edit my answer accordingly. –  Molly7244 Dec 24 '09 at 22:11

I've found a semi-satisfactory way to do it. Make sure you set up the second monitor on the right hand side, then:

  • Open the preferences dialog (Tools --> Preferences)
  • In the interface tab, choose Native, and un-tick "Embed video in interface" (this enables the controls to be separated from the video)
  • Choose "All" in the "Show settings" box at the bottom left of the preferences window
  • Choose the video options from the left
  • Tick Fullscreen video output
  • Scroll down and set an X and Y position that are on the second monitor - so set an X position larger then the width of the first screen. The value of the Y coordinate doesn't matter much, but mustn't be negative otherwise both values will be ignored.
  • Save the settings

Now, when you start a video, it will run full screen on the second monitor. The disadvantages of the above compared to the Mac OS "Fullscreen Video device" menu are:

  • Sometimes you will see the video window for a moment before it goes full screen.
  • It's a pain in the neck to set up, and kind of needs to be set permanently
  • You can't have the non-fullscreen video on the first screen to preview/cue it up before you start & if you exit full screen mode you get a video window on the second monitor, which isn't what you want in a presentation type situation.
  • It only works with the second output on the right. With it on the left, VLC seems to treat a negative window position as "use defaults". I haven't tried putting the second monitor above or below - presumably only one of those will work.
share|improve this answer

Maybe this solution might help...

At our church, we sometimes need to display video content on the second monitor which is our projector screen. We also chose VLC to display the content, and for similar reasons as stated we found it rather distracting on having to drag the 'player' window of VLC on to the second monitor. We also wanted to come up with a really simple solution so that our less computer-savvy operators could find it really easy to show video content.

Using VLC 1.1.4 under Windows Vista, we came up with the following batch script, which we've put into a file (Vlc_Starter.bat) which can be placed anywhere (for example on the Windows desktop):

set vlcPath="C:\Program Files\VideoLAN\VLC\vlc.exe"

%vlcPath% %1 --video-x=1600 --video-y=400 --width=300 --height=300 --fullscreen --no-video-title-show --no-embedded-video --no-qt-fs-controller

This enables us to simply drag-and-drop media files onto the Vlc_Starter.bat file icon, which automatically loads and starts the video on the second monitor. We can then control and stop the video playing from the VLC 'controller' window as normal.

If you wanted to use this, you would have to adapt the Vlc_Starter.bat to match the setup of your second monitor - this is the video-x=... and video-y=... option in the script. You might also need to change the vlcPath=... setting for your install location of VLC. You can also adapt the script to display DVD content (replace the %1 to something like dvdsimple://g:\@2 where 'g' is the drive and '2' is the DVD title number), or make the script into a Windows shortcut instead (I won't give details as my posting is already pretty long...!)

share|improve this answer

protected by studiohack Apr 28 '11 at 10:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.