Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently built a PC with an ATI Radeon HD 5750. I have installed Fedora 11 and installed the device driver for the Radeon 5700 series proprietary drivers. I wanted to see if there is graphics hardware acceleration. I typed in glxinfo at the terminal and I got:

X Error of failed request:  BadRequest (invalid request code or no such operation)
Major opcode of failed request:  135 (GLX)
Minor opcode of failed request:  19 (X_GLXQueryServerString)
Serial number of failed request:  14
Current serial number in output stream:  14

I don't know how to fix this. I tried to go to the ATI Catalyst Control Center; that worked, but the ATI Catalyst Control Center (Administrator) doesn't work. If anyone knows how to fix this problem then please let me know.

share|improve this question

migrated from stackoverflow.com Dec 25 '09 at 20:37

This question came from our site for professional and enthusiast programmers.

1 Answer 1

ATI Linux support sucks. You'll save yourself a lot of headaches by replacing it with an NVIDIA card if you plan to use Linux more heavily.

That being said, these type of errors are usually due to a bug in the ATI installer on a 64-bit system (which you may have?), which tries to get the system to load a 32-bit driver instead of the 64-bit one. If that's the case in your situation, you'll need to do this (as root or sudo):

mv /usr/lib/dri/fglrx_dri.so /usr/lib/dri/original-fglrx_dri.so
ln -s /usr/lib64/dri/fglrx_dri.so /usr/lib/dri/fglrx_dri.so

Then do:

aticonfig --initial

If that doesn't work, you can change it back:

mv /usr/lib/dri/original-fglrx_dri.so /usr/lib/dri/fglrx_dri.so
share|improve this answer
    
Agreed and 100% right with the crappy support. ATI driver is the worst on every platform, no need for further explanation I guess. –  Shiki May 24 '10 at 11:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.